summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSven Wegener <swegener@gentoo.org>2004-10-15 21:03:50 +0000
committerSven Wegener <swegener@gentoo.org>2004-10-15 21:03:50 +0000
commit3c04fa2c14c387aea2c081be7147be8dc7331f2e (patch)
treeafc93fcbbfb01512cbee2c14af5e132c20c8797b /app-misc/screen/screen-4.0.2.ebuild
parentadd flac/aac to the audio list #67604 (Manifest recommit) (diff)
downloadgentoo-2-3c04fa2c14c387aea2c081be7147be8dc7331f2e.tar.gz
gentoo-2-3c04fa2c14c387aea2c081be7147be8dc7331f2e.tar.bz2
gentoo-2-3c04fa2c14c387aea2c081be7147be8dc7331f2e.zip
Fixed the nethack USE flag which was always activated. Thanks to Horst Schirmeier <gentoo@schirmeier.com> in bug #67127. Modified to use non-lazy bindings.
Diffstat (limited to 'app-misc/screen/screen-4.0.2.ebuild')
-rw-r--r--app-misc/screen/screen-4.0.2.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/app-misc/screen/screen-4.0.2.ebuild b/app-misc/screen/screen-4.0.2.ebuild
index c06b0f60611c..06b574a76b3f 100644
--- a/app-misc/screen/screen-4.0.2.ebuild
+++ b/app-misc/screen/screen-4.0.2.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.2.ebuild,v 1.19 2004/09/04 04:15:32 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.2.ebuild,v 1.20 2004/10/15 21:03:50 swegener Exp $
inherit eutils flag-o-matic
DESCRIPTION="Screen is a full-screen window manager that multiplexes a physical terminal between several processes"
HOMEPAGE="http://www.gnu.org/software/screen/"
-#SRC_URI="ftp://ftp.uni-erlangen.de/pub/utilities/screen/${P}.tar.gz"
SRC_URI="mirror://gnu/screen/${P}.tar.gz"
LICENSE="GPL-2"
@@ -56,8 +55,10 @@ src_compile() {
# check config.h for other settings such as the
# max-number of windows allowed by screen.
append-flags "-DPTYMODE=0620 -DPTYGROUP=5"
+ append-ldflags -Wl,-z,now
+
use pam && append-flags "-DUSE_PAM"
- use nethack && append-flags "-DNETHACK"
+ use nethack || append-flags "-DNONETHACK"
econf \
$(use_enable pam) \