summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/screen/ChangeLog7
-rw-r--r--app-misc/screen/screen-4.0.2.ebuild7
2 files changed, 10 insertions, 4 deletions
diff --git a/app-misc/screen/ChangeLog b/app-misc/screen/ChangeLog
index 9d15ef00bd20..4d2cd0634d64 100644
--- a/app-misc/screen/ChangeLog
+++ b/app-misc/screen/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-misc/screen
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/ChangeLog,v 1.75 2004/10/13 20:37:27 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/ChangeLog,v 1.76 2004/10/15 21:03:50 swegener Exp $
+
+ 15 Oct 2004; Sven Wegener <swegener@gentoo.org> screen-4.0.2.ebuild:
+ Fixed the nethack USE flag which was always activated. Thanks to Horst
+ Schirmeier <gentoo@schirmeier.com> in bug #67127. Modified to use non-lazy
+ bindings.
13 Oct 2004; Sven Wegener <swegener@gentoo.org> metadata.xml:
Added to the shell-tools herd.
diff --git a/app-misc/screen/screen-4.0.2.ebuild b/app-misc/screen/screen-4.0.2.ebuild
index c06b0f60611c..06b574a76b3f 100644
--- a/app-misc/screen/screen-4.0.2.ebuild
+++ b/app-misc/screen/screen-4.0.2.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.2.ebuild,v 1.19 2004/09/04 04:15:32 swegener Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/screen/screen-4.0.2.ebuild,v 1.20 2004/10/15 21:03:50 swegener Exp $
inherit eutils flag-o-matic
DESCRIPTION="Screen is a full-screen window manager that multiplexes a physical terminal between several processes"
HOMEPAGE="http://www.gnu.org/software/screen/"
-#SRC_URI="ftp://ftp.uni-erlangen.de/pub/utilities/screen/${P}.tar.gz"
SRC_URI="mirror://gnu/screen/${P}.tar.gz"
LICENSE="GPL-2"
@@ -56,8 +55,10 @@ src_compile() {
# check config.h for other settings such as the
# max-number of windows allowed by screen.
append-flags "-DPTYMODE=0620 -DPTYGROUP=5"
+ append-ldflags -Wl,-z,now
+
use pam && append-flags "-DUSE_PAM"
- use nethack && append-flags "-DNETHACK"
+ use nethack || append-flags "-DNONETHACK"
econf \
$(use_enable pam) \