summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-06-20 04:30:46 +0000
committerMike Frysinger <vapier@gentoo.org>2003-06-20 04:30:46 +0000
commit8a494decde97cafb0a2100f9a429b913863e5425 (patch)
treee8be29f62473518ee77103bef0b328b09711aac7 /app-emulation
parentChanged x11-misc/nxtvepg to media-tv/nxtvepg (diff)
downloadgentoo-2-8a494decde97cafb0a2100f9a429b913863e5425.tar.gz
gentoo-2-8a494decde97cafb0a2100f9a429b913863e5425.tar.bz2
gentoo-2-8a494decde97cafb0a2100f9a429b913863e5425.zip
version bump/fix for #11465
Diffstat (limited to 'app-emulation')
-rw-r--r--app-emulation/XWine/Manifest8
-rw-r--r--app-emulation/XWine/XWine-0.3.1.ebuild40
2 files changed, 43 insertions, 5 deletions
diff --git a/app-emulation/XWine/Manifest b/app-emulation/XWine/Manifest
index b43c3a4d20b9..3a3c05430aff 100644
--- a/app-emulation/XWine/Manifest
+++ b/app-emulation/XWine/Manifest
@@ -1,5 +1,3 @@
-MD5 5ce58d6b26e085e7fb36560432a4efb2 ChangeLog 1366
-MD5 6af1c0fafb6d82dff8b69ef82c4cd02b XWine-0.2.2.ebuild 1624
-MD5 1d4b5efd7790f6d7965fa2d6e1179ed8 XWine-0.3.ebuild 1617
-MD5 64fb5b2e1a244d661d62a04a5e2c6884 files/digest-XWine-0.2.2 66
-MD5 8aa222e2b09b9e9f4b85f70e89f3f698 files/digest-XWine-0.3 64
+MD5 4837a922513d4f243f19eb64789f2556 files/digest-XWine-0.3.1 66
+MD5 ff9a2dcd35e63b22c0994ea9e43383ba XWine-0.3.1.ebuild 1099
+MD5 5826f0339076ffbcfeb2c4054cafdd13 ChangeLog 1394
diff --git a/app-emulation/XWine/XWine-0.3.1.ebuild b/app-emulation/XWine/XWine-0.3.1.ebuild
new file mode 100644
index 000000000000..90e342869360
--- /dev/null
+++ b/app-emulation/XWine/XWine-0.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.3.1.ebuild,v 1.1 2003/06/20 04:30:41 vapier Exp $
+
+DESCRIPTION="GTK+ frontend for Wine"
+HOMEPAGE="http://darken.tuxfamily.org/pages/xwine_en.html"
+SRC_URI="http://darken.tuxfamily.org/projets/${P}_en.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc "
+IUSE="nls"
+
+DEPEND="=x11-libs/gtk+-1*
+ sys-devel/bison
+ >=gnome-base/gnome-libs-1.4.2
+ >=gnome-base/ORBit-0.5.17
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${P}_en
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ # Don't need to install docs twice
+ rm -rf ${D}/usr/share/doc/xwine
+ dodoc doc/Manual* FAQ* BUGS COPYING AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo "${PN} requires a setup Wine to start....It is recommended"
+ einfo "that you run winesetuptk prior to running ${PN} to setup"
+ einfo "a base Wine install"
+ einfo ""
+ einfo "You should also emerge wine or winex at this point"
+}