summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-emulation/XWine/XWine-0.3.1.ebuild')
-rw-r--r--app-emulation/XWine/XWine-0.3.1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-emulation/XWine/XWine-0.3.1.ebuild b/app-emulation/XWine/XWine-0.3.1.ebuild
new file mode 100644
index 000000000000..90e342869360
--- /dev/null
+++ b/app-emulation/XWine/XWine-0.3.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/XWine/XWine-0.3.1.ebuild,v 1.1 2003/06/20 04:30:41 vapier Exp $
+
+DESCRIPTION="GTK+ frontend for Wine"
+HOMEPAGE="http://darken.tuxfamily.org/pages/xwine_en.html"
+SRC_URI="http://darken.tuxfamily.org/projets/${P}_en.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 -ppc -sparc "
+IUSE="nls"
+
+DEPEND="=x11-libs/gtk+-1*
+ sys-devel/bison
+ >=gnome-base/gnome-libs-1.4.2
+ >=gnome-base/ORBit-0.5.17
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${P}_en
+
+src_compile() {
+ econf `use_enable nls` || die
+ emake || die
+}
+
+src_install() {
+ einstall || die
+ # Don't need to install docs twice
+ rm -rf ${D}/usr/share/doc/xwine
+ dodoc doc/Manual* FAQ* BUGS COPYING AUTHORS ChangeLog NEWS README TODO
+}
+
+pkg_postinst() {
+ einfo "${PN} requires a setup Wine to start....It is recommended"
+ einfo "that you run winesetuptk prior to running ${PN} to setup"
+ einfo "a base Wine install"
+ einfo ""
+ einfo "You should also emerge wine or winex at this point"
+}