summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2007-07-15 03:43:09 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2007-07-15 03:43:09 +0000
commit1c6bfab0a3042d43c9e63c6920f06cfa356b4eb0 (patch)
treed717f27f69cbd02b53d50a1966aa5778227fe578 /app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild
parentwhitespace (diff)
downloadgentoo-2-1c6bfab0a3042d43c9e63c6920f06cfa356b4eb0.tar.gz
gentoo-2-1c6bfab0a3042d43c9e63c6920f06cfa356b4eb0.tar.bz2
gentoo-2-1c6bfab0a3042d43c9e63c6920f06cfa356b4eb0.zip
Bump. Various SSL fixes, default vhost is now name-based, servername check fixed, config file writes to /etc/apache2/conf.d/system-config-httpd.conf, and more.
(Portage version: 2.1.3_rc8)
Diffstat (limited to 'app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild')
-rw-r--r--app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild b/app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild
new file mode 100644
index 000000000000..a9f7aad0a333
--- /dev/null
+++ b/app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild,v 1.1 2007/07/15 03:43:09 dberkholz Exp $
+
+inherit python eutils rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="7"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Apache configuration tool"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-libs/alchemist
+ =dev-python/pygtk-2*
+ dev-lang/python
+ =dev-python/gnome-python-2*
+ >=net-www/apache-2.0.52-r3
+ sys-apps/usermode
+ dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxslt python; then
+ local msg="Build dev-libs/libxslt with USE=python"
+ eerror "$msg"
+ die "$msg"
+ fi
+}
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentooify.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}