summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-admin/system-config-httpd/ChangeLog12
-rw-r--r--app-admin/system-config-httpd/files/1.4.3-gentooify.patch95
-rw-r--r--app-admin/system-config-httpd/files/digest-system-config-httpd-1.4.33
-rw-r--r--app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild55
4 files changed, 163 insertions, 2 deletions
diff --git a/app-admin/system-config-httpd/ChangeLog b/app-admin/system-config-httpd/ChangeLog
index ffd404b23a06..7cdbfe0c2795 100644
--- a/app-admin/system-config-httpd/ChangeLog
+++ b/app-admin/system-config-httpd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/system-config-httpd
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-httpd/ChangeLog,v 1.2 2006/09/05 21:54:33 dberkholz Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-httpd/ChangeLog,v 1.3 2007/07/15 03:43:09 dberkholz Exp $
+
+*system-config-httpd-1.4.3 (15 Jul 2007)
+
+ 15 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>;
+ +files/1.4.3-gentooify.patch, +system-config-httpd-1.4.3.ebuild:
+ Bump. Various SSL fixes, default vhost is now name-based, servername check
+ fixed, config file writes to /etc/apache2/conf.d/system-config-httpd.conf,
+ and more.
05 Sep 2006; Donnie Berkholz <dberkholz@gentoo.org>;
system-config-httpd-1.3.3.ebuild:
diff --git a/app-admin/system-config-httpd/files/1.4.3-gentooify.patch b/app-admin/system-config-httpd/files/1.4.3-gentooify.patch
new file mode 100644
index 000000000000..09cda3c575ed
--- /dev/null
+++ b/app-admin/system-config-httpd/files/1.4.3-gentooify.patch
@@ -0,0 +1,95 @@
+Index: README.1st
+===================================================================
+RCS file: /usr/local/CVS/apacheconf/README.1st,v
+retrieving revision 1.4
+diff -u -b -B -r1.4 README.1st
+--- README.1st 20 Nov 2006 16:41:44 -0000 1.4
++++ README.1st 15 Jul 2007 03:31:11 -0000
+@@ -21,7 +21,7 @@
+ Small update on the plan of parsing:
+
+ As with the newer httpd packages we started supporting and automatically
+-including /etc/httpd/conf.d/* in our default setup, so the plan is to
++including /etc/apache2/conf.d/* in our default setup, so the plan is to
+ store the configuration generated by system-config-httpd in a file (or more
+ files) in that directory.
+
+Index: system-config-httpd.1
+===================================================================
+RCS file: /usr/local/CVS/apacheconf/system-config-httpd.1,v
+retrieving revision 1.2
+diff -u -b -B -r1.2 system-config-httpd.1
+--- system-config-httpd.1 11 Jan 2007 11:57:56 -0000 1.2
++++ system-config-httpd.1 15 Jul 2007 03:31:11 -0000
+@@ -26,7 +26,7 @@
+ .SH "BUGS"
+ Not all possible checks for correct values are done yet.
+
+-The current /etc/httpd/conf/httpd.conf file is \fBNOT\fR parsed, so changing the
++The current /etc/apache2/conf/httpd.conf file is \fBNOT\fR parsed, so changing the
+ configuration with system-config-httpd will overwrite any manual changes to the httpd.conf file or
+ the changes done with system-config-httpd are discarded. In case of overwriting the manually
+ editied file a backup file will be generated.
+Index: src/ApacheBase.py
+===================================================================
+RCS file: /usr/local/CVS/apacheconf/src/ApacheBase.py,v
+retrieving revision 1.29
+diff -u -b -B -r1.29 ApacheBase.py
+--- src/ApacheBase.py 10 Nov 2006 16:43:46 -0000 1.29
++++ src/ApacheBase.py 15 Jul 2007 03:31:12 -0000
+@@ -4349,7 +4349,7 @@
+
+ # Compute md5sum of currently installed httpd.conf
+ try:
+- rmd5 = hexstr (md5 (open ('/etc/httpd/conf.d/system-config-httpd.conf', 'r').read ()).digest())
++ rmd5 = hexstr (md5 (open ('/etc/apache2/modules.d/system-config-httpd.conf', 'r').read ()).digest())
+ except:
+ rmd5 = ''
+
+@@ -4361,14 +4361,14 @@
+ if omd5 != rmd5:
+ if force:
+ try:
+- os.remove ('/etc/httpd/conf.d/system-config-httpd.conf.bak')
++ os.remove ('/etc/apache2/modules.d/system-config-httpd.conf.bak')
+ except:
+ pass
+ try:
+- os.rename ('/etc/httpd/conf.d/system-config-httpd.conf', '/etc/httpd/conf.d/system-config-httpd.conf.bak')
++ os.rename ('/etc/apache2/modules.d/system-config-httpd.conf', '/etc/apache2/modules.d/system-config-httpd.conf.bak')
+ except:
+ pass
+- open ('/etc/httpd/conf.d/system-config-httpd.conf', 'w').write (result)
++ open ('/etc/apache2/modules.d/system-config-httpd.conf', 'w').write (result)
+ open ('/usr/share/system-config-httpd/system-config-httpd.conf.md5', 'w').write (nmd5)
+ local_box.write (ctx)
+ return 0
+@@ -4377,7 +4377,7 @@
+ else:
+ return -2
+ else:
+- open ('/etc/httpd/conf.d/system-config-httpd.conf', 'w').write (result)
++ open ('/etc/apache2/modules.d/system-config-httpd.conf', 'w').write (result)
+ open ('/usr/share/system-config-httpd/system-config-httpd.conf.md5', 'w').write (nmd5)
+ local_box.write (ctx)
+ return 0
+Index: src/rpm.xml
+===================================================================
+RCS file: /usr/local/CVS/apacheconf/src/rpm.xml,v
+retrieving revision 1.17
+diff -u -b -B -r1.17 rpm.xml
+--- src/rpm.xml 10 Nov 2006 16:43:47 -0000 1.17
++++ src/rpm.xml 15 Jul 2007 03:31:12 -0000
+@@ -7,10 +7,10 @@
+ <datatree>
+ <apache TYPE="LIST">
+ <serveroptions TYPE="LIST">
+- <ServerRoot TYPE="STRING" VALUE="/etc/httpd"/>
++ <ServerRoot TYPE="STRING" VALUE="/etc/apache2"/>
+ <ServerName TYPE="STRING" VALUE=""/>
+ <ServerAdmin TYPE="STRING" VALUE="root@localhost"/>
+- <CoreDumpDirectory TYPE="STRING" VALUE="/etc/httpd"/>
++ <CoreDumpDirectory TYPE="STRING" VALUE="/etc/apache2"/>
+ <listener ANONYMOUS="TRUE" ATOMIC="TRUE" TYPE="LIST">
+ </listener>
+ <Port TYPE="INT" VALUE="80"/>
diff --git a/app-admin/system-config-httpd/files/digest-system-config-httpd-1.4.3 b/app-admin/system-config-httpd/files/digest-system-config-httpd-1.4.3
new file mode 100644
index 000000000000..06a733c63123
--- /dev/null
+++ b/app-admin/system-config-httpd/files/digest-system-config-httpd-1.4.3
@@ -0,0 +1,3 @@
+MD5 5d8e734b8faa609d64cc4052283a4b71 system-config-httpd-1.4.3-1.fc7.src.rpm 1083633
+RMD160 daa04cc38823038e0a78acdfe42c27d520264fbf system-config-httpd-1.4.3-1.fc7.src.rpm 1083633
+SHA256 d0a67894ca8ef14c0d7b4bc95d67aef81b5650e43378006ef100e2b628a23e0d system-config-httpd-1.4.3-1.fc7.src.rpm 1083633
diff --git a/app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild b/app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild
new file mode 100644
index 000000000000..a9f7aad0a333
--- /dev/null
+++ b/app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/system-config-httpd/system-config-httpd-1.4.3.ebuild,v 1.1 2007/07/15 03:43:09 dberkholz Exp $
+
+inherit python eutils rpm
+
+# Tag for which Fedora Core version it's from
+FCVER="7"
+# Revision of the RPM. Shouldn't affect us, as we're just grabbing the source
+# tarball out of it
+RPMREV="1"
+
+DESCRIPTION="Apache configuration tool"
+HOMEPAGE="http://fedora.redhat.com/projects/config-tools/"
+SRC_URI="mirror://fedora/development/source/SRPMS/${P}-${RPMREV}.fc${FCVER}.src.rpm"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc ~x86"
+IUSE=""
+RDEPEND="dev-libs/alchemist
+ =dev-python/pygtk-2*
+ dev-lang/python
+ =dev-python/gnome-python-2*
+ >=net-www/apache-2.0.52-r3
+ sys-apps/usermode
+ dev-libs/libxslt"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ dev-util/intltool"
+
+pkg_setup() {
+ if ! built_with_use dev-libs/libxslt python; then
+ local msg="Build dev-libs/libxslt with USE=python"
+ eerror "$msg"
+ die "$msg"
+ fi
+}
+
+src_unpack() {
+ rpm_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gentooify.patch
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ make_desktop_entry /usr/bin/${PN}
+
+ fperms 644 /etc/pam.d/${PN}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/share/${PN}
+}