summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/gummiboot/gummiboot-45.ebuild')
-rw-r--r--sys-boot/gummiboot/gummiboot-45.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/sys-boot/gummiboot/gummiboot-45.ebuild b/sys-boot/gummiboot/gummiboot-45.ebuild
new file mode 100644
index 0000000..33dd45f
--- /dev/null
+++ b/sys-boot/gummiboot/gummiboot-45.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit eutils linux-info
+
+DESCRIPTION="Minimalistic UEFI bootloader"
+HOMEPAGE="http://freedesktop.org/wiki/Software/gummiboot/"
+SRC_URI="http://dev.gentoo.org/~mgorny/dist/${P}.tar.xz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="sys-apps/util-linux"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ app-text/docbook-xsl-stylesheets
+ dev-libs/libxslt
+ || (
+ =sys-boot/gnu-efi-3.0s
+ =sys-boot/gnu-efi-3.0u
+ )"
+
+pkg_pretend() {
+ # CONFIG_EFI_STUB is required to boot a kernel with gummiboot
+ local CONFIG_CHECK="~EFI_STUB"
+ check_extra_config
+}
+
+src_prepare() {
+ epatch_user
+}