summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Crandall <triquetra@triquetradevelopment.com>2016-01-17 17:58:14 -0600
committerDavid Crandall <triquetra@triquetradevelopment.com>2016-01-17 17:58:14 -0600
commit230413ddf23d166989984f3ed9e7f1e9c5812dc9 (patch)
treeb8f549251c7c30dec98f57bdfea722d65c032bc6
parentRemoved e-builds now available and maintained elsewhere. (diff)
downloadtriquetra-230413ddf23d166989984f3ed9e7f1e9c5812dc9.tar.gz
triquetra-230413ddf23d166989984f3ed9e7f1e9c5812dc9.tar.bz2
triquetra-230413ddf23d166989984f3ed9e7f1e9c5812dc9.zip
Added hg-git 0.8.4 ebuild
-rw-r--r--dev-vcs/hg-git/Manifest2
-rw-r--r--dev-vcs/hg-git/hg-git-0.8.4.ebuild25
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-vcs/hg-git/Manifest b/dev-vcs/hg-git/Manifest
new file mode 100644
index 0000000..d0d3c49
--- /dev/null
+++ b/dev-vcs/hg-git/Manifest
@@ -0,0 +1,2 @@
+DIST hg-git-0.8.4.tar.gz 96421 SHA256 aa8f1d4ccf110480950a7de82f30c1233e20c8148a384f0a8f43779686cfd90c SHA512 9a6d01489eaf9252a09c3778ddbde562f31637a7d8d9b67f544af5aaec31426ab74f05e065405c56ad37d58ae82ef702ef5a6e1ad9a9ea5aa23af98cf42726b1 WHIRLPOOL beb6b37911f9b4cff902fa35a857eb79b6eb4adca0077c2413801b93f64b6f450df5781716c31ccc6075313ab3d08ded2ea3011f767442945f694f414bdfe0fc
+EBUILD hg-git-0.8.4.ebuild 710 SHA256 4786517ffaf04d5a2a7033c019de18e182d192d5abce5f818ccabc236096c680 SHA512 4c1cf8a2c5e4c02dbcc9ec884d7a2c9a6b0b701652f885b2e0b106fb4343874008523ee60dc1c41f5e774e7ee0adbc795a59ef52d97cab91664096cdb38db2fa WHIRLPOOL 298199c3c1324addb32872b0e44db4602b4bd5acdffa6131627250b5d04e00fcb1ad615e7b62e73f3c514688d0c333caafe25ea65947303632e8d06dfa5f1ad5
diff --git a/dev-vcs/hg-git/hg-git-0.8.4.ebuild b/dev-vcs/hg-git/hg-git-0.8.4.ebuild
new file mode 100644
index 0000000..e2c3fb3
--- /dev/null
+++ b/dev-vcs/hg-git/hg-git-0.8.4.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="push to and pull from a Git repository using Mercurial"
+HOMEPAGE="http://hg-git.github.io https://pypi.python.org/pypi/hg-git"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND="
+ >=dev-vcs/mercurial-1.9.3[${PYTHON_USEDEP}]
+ >=dev-python/dulwich-0.9.4[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"