summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-20 16:44:01 +0200
committerHenry Gebhardt <hsggebhardt@googlemail.com>2011-05-20 16:45:31 +0200
commit1800052b91535e3abba6554c379b72e6b24bcaf9 (patch)
treef59e6763f3e8b476354433b9e649a81627fd0941
parentsys-apps/systemd-27: Version bump, remove sysv use-flag (diff)
downloadsystemd-1800052b91535e3abba6554c379b72e6b24bcaf9.tar.gz
systemd-1800052b91535e3abba6554c379b72e6b24bcaf9.tar.bz2
systemd-1800052b91535e3abba6554c379b72e6b24bcaf9.zip
sys-apps/systemd-27: Add postinst check for /var/lock, clean messages
-rw-r--r--sys-apps/systemd/Manifest2
-rw-r--r--sys-apps/systemd/systemd-27.ebuild24
2 files changed, 21 insertions, 5 deletions
diff --git a/sys-apps/systemd/Manifest b/sys-apps/systemd/Manifest
index 59d3e93..15f5606 100644
--- a/sys-apps/systemd/Manifest
+++ b/sys-apps/systemd/Manifest
@@ -1,6 +1,6 @@
DIST systemd-26.tar.bz2 791117 RMD160 06836ca8daf0c5ebc113940357289348561dac56 SHA1 901486904aeb1d8a3ae20e5971afd9b42b847450 SHA256 d7a222c09cdb0a9eebe97c7c499c458cc29ef8b3b2d0ca79bb949b2fd3d077d3
DIST systemd-27.tar.bz2 809898 RMD160 bd9a2b0c065ff7d07e0fb5d0346ab9e355aaa6cf SHA1 2ccd50681a52ae5de5e5c5f1c3fc9233dfb26ad1 SHA256 3a8d978721a404b25df6a59dc666cf30a02f14d3c680c4f8c3a91e68a9407e53
EBUILD systemd-26.ebuild 4327 RMD160 d26de8d5b632a0c96b2dc19441d0d0d57bbfa2da SHA1 188fa736286c9bbc48147b732512243ed0e9a60d SHA256 0499bf01d2e23cf5106139597d0d2eec54625463da808285f9562dc7a6c735e1
-EBUILD systemd-27.ebuild 4078 RMD160 2516ff050748c44097403c92c54fb7b9c56bc1fa SHA1 7aa76674c87950ff894b138be53621c462e2d09b SHA256 c03b2d6811593fae84d8bf2e0f8794f2b824b4512ab3b356faed05d45052b8eb
+EBUILD systemd-27.ebuild 4344 RMD160 4ac23423cfac622b84f6cb5d88ad8322d6aa881c SHA1 5efab5bf04ca4dcd3b2f597eb8c29d1034a7465e SHA256 9e298939418589e22e9916d5a17937c2a12ac9c703d50c3192f2834a9cfa7080
EBUILD systemd-9999.ebuild 4215 RMD160 a7fda5c858136bd474c2a23fd5c630e84d6f412d SHA1 75eb64200629c890a8cdd554b58c57e06493d4ca SHA256 da9533edb1b2c531692c6d4a3b03e2b46ec82fb2fedbabeb870ac85609c711a5
MISC metadata.xml 737 RMD160 cdd440f38c039bfa7967fd713ef238588c2e1fb4 SHA1 1dea5e1d1e388bf43131297667bb4dbba10e65dd SHA256 042b1b68c02c274920954280705e21c2ca2ef5eece3229aab03d8dd43e06422d
diff --git a/sys-apps/systemd/systemd-27.ebuild b/sys-apps/systemd/systemd-27.ebuild
index 8b3724b..512b2df 100644
--- a/sys-apps/systemd/systemd-27.ebuild
+++ b/sys-apps/systemd/systemd-27.ebuild
@@ -111,6 +111,7 @@ check_mtab_is_symlink() {
ewarn "${ROOT}etc/mtab must be a symlink to ${ROOT}proc/self/mounts!"
ewarn "To correct that, execute"
ewarn " $ ln -sf '${ROOT}proc/self/mounts' '${ROOT}etc/mtab'"
+ elog
fi
}
@@ -119,20 +120,33 @@ systemd_machine_id_setup() {
if ! "${ROOT}"bin/systemd-machine-id-setup; then
ewarn "Setting up /etc/machine-id failed, to fix it please see"
ewarn " http://lists.freedesktop.org/archives/dbus/2011-March/014187.html"
+ elog
elif test ! -L "${ROOT}"var/lib/dbus/machine-id; then
# This should be fixed in the dbus ebuild, but we warn about it here.
ewarn "${ROOT}var/lib/dbus/machine-id ideally should be a symlink to"
ewarn "${ROOT}etc/machine-id to make it clear that they have the same"
ewarn "content."
+ elog
+ else
+ einfo
fi
}
check_var_run_is_symlink() {
if test ! -L "${ROOT}"var/run; then
- einfo "${ROOT}var/run should be a symlink to ${ROOT}run. This is not"
- einfo "trivial to change, and there is no hurry as it is currently"
- einfo "bind-mounted at boot-time. You may be able to create the"
- einfo "symlink by lazily unmounting ${ROOT}var/run first."
+ elog "${ROOT}var/run should be a symlink to ${ROOT}run. This is not"
+ elog "trivial to change, and there is no hurry as it is currently"
+ elog "bind-mounted at boot-time. You may be able to create the"
+ elog "symlink by lazily unmounting ${ROOT}var/run first."
+ elog
+ fi
+}
+
+check_var_lock_is_symlink() {
+ if test ! -L "${ROOT}"var/lock; then
+ elog "${ROOT}var/lock should be a symlink to ${ROOT}run/lock, see"
+ elog " https://lwn.net/Articles/436012/"
+ elog
fi
}
@@ -140,6 +154,7 @@ pkg_postinst() {
check_mtab_is_symlink
systemd_machine_id_setup
check_var_run_is_symlink
+ check_var_lock_is_symlink
# Inform user about extra configuration
elog "You may need to perform some additional configuration for some"
@@ -147,6 +162,7 @@ pkg_postinst() {
elog "handling tmpfiles:"
elog " $ man modules-load.d"
elog " $ man tmpfiles.d"
+ elog
ewarn "This is a work-in-progress ebuild. You may brick your system. Have fun!"
}