aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Shelton <stuart@shelton.me>2016-05-04 09:43:46 +0100
committerStuart Shelton <stuart@shelton.me>2016-05-04 09:43:46 +0100
commitfa9185d761e180a766014f5a770202e3d37cc063 (patch)
treea7520f3a346afd0a0182334e333cddacae0f3c7e /dev-libs
parentUpdate sys-apps/gentoo-functions-0.10 (diff)
downloadsrcshelton-fa9185d761e180a766014f5a770202e3d37cc063.tar.gz
srcshelton-fa9185d761e180a766014f5a770202e3d37cc063.tar.bz2
srcshelton-fa9185d761e180a766014f5a770202e3d37cc063.zip
Add dev-libs/openssl-1.0.2h
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/openssl/Manifest2
-rw-r--r--dev-libs/openssl/openssl-1.0.2h.ebuild325
2 files changed, 327 insertions, 0 deletions
diff --git a/dev-libs/openssl/Manifest b/dev-libs/openssl/Manifest
index da0865c6..8e408f59 100644
--- a/dev-libs/openssl/Manifest
+++ b/dev-libs/openssl/Manifest
@@ -60,6 +60,7 @@ DIST openssl-1.0.2d.tar.gz 5295447 SHA256 671c36487785628a703374c652ad2cebea45fa
DIST openssl-1.0.2e.tar.gz 5256555 SHA256 e23ccafdb75cfcde782da0151731aa2185195ac745eea3846133f2e05c0e0bff SHA512 b73f114a117ccab284cf5891dac050e3016d28e0b1fc71639442cdb42accef676115af90a12deff4bcc1f599cc0cbdeb38142cbf4570bd7d03634786ad32c95f WHIRLPOOL 8e1c1800a66f57fa78dc391e717e4b2bdf0e6e37a837c5ac033d7a4b1a6437451c7e7540c4ec2f75f936a2d2ef4f9293b42c76f51b0c9c93706639589612f196
DIST openssl-1.0.2f.tar.gz 5258384 SHA256 932b4ee4def2b434f85435d9e3e19ca8ba99ce9a065a61524b429a9d5e9b2e9c SHA512 50abf6dc94cafd06e7fd20770808bdc675c88daa369e4f752bd584ab17f72a57357c1ca1eca3c83e6745b5a3c9c73c99dce70adaa904d73f6df4c75bc7138351 WHIRLPOOL 179e1b5ad38c50a4c8110024aa7b33c53634c39690917e3bf5c2099548430beef96132ae9f9588ff0cedd6e08bb216a8d36835baaaa04e506fb3fbaed37d31c9
DIST openssl-1.0.2g.tar.gz 5266102 SHA256 b784b1b3907ce39abf4098702dade6365522a253ad1552e267a9a0e89594aa33 SHA512 4d96b6c8a232203483d6e8bee81da01ba10977bfbac92f25304a36dec9ea584b7ef917bc45e097cc7dbe681d71a4570d649c22244c178393ae91fab48323f735 WHIRLPOOL aedbd82af0a550e8329a84312fae492f3bb3cb04af763fc9ef532099b2b2e61a55e4a7cfb06085f045740e2b692bbdb3ecb8bf5ca82f46325c3caf22d2317ffb
+DIST openssl-1.0.2h.tar.gz 5274412 SHA256 1d4007e53aad94a5b2002fe045ee7bb0b3d98f1a47f8b2bc851dcd1c74332919 SHA512 780601f6f3f32f42b6d7bbc4c593db39a3575f9db80294a10a68b2b0bb79448d9bd529ca700b9977354cbdfc65887c76af0aa7b90d3ee421f74ab53e6f15c303 WHIRLPOOL 41b6cf0c08b547f1432dc8167a4c7835da0b6907f8932969e0a352fab8bdbb4d8f612a5bf431e415d93ff1c8238652b2ee3ce0bd935cc2f59e8ea4f40fe6b5d6
DIST openssl-c_rehash.sh.1.7 4167 SHA256 4999ee79892f52bd6a4a7baba9fac62262454d573bbffd72685d3aae9e48cee0 SHA512 55e8c2e827750a4f375cb83c86bfe2d166c01ffa5d7e9b16657b72b38b747c8985dd2c98f854c911dfbbee2ff3e92aff39fdf089d979b2e3534b7685ee8b80da WHIRLPOOL c88f06a3b8651f76b6289552cccceb64e13f6697c5f0ce3ff114c781ce1c218912b8ee308af9d087cd76a9600fdacda1953175bff07d7d3eb21b0c0b7f4f1ce1
EBUILD openssl-1.0.1g-r1.ebuild 11170 SHA256 6a84cbdfe9dfe8dc9ec263a5e5b50a8d0c3fc282e849673502565d3e184bc030 SHA512 b4b5d14dfb0f231d039814fc88edaf5cd2d9ec6b5a1d3fbefacf65602c5414a3319e5e02c108cb815c7210de8d3151f6741909caba8256e9441050fcd0607bba WHIRLPOOL 8010ac052bb298bee061b50987a432ee341ad7fa0eb3601c497e3b399ad6712be3c0f0f1605a2a8bff44dbe732ce063cee6d4bfdfae9f980308919e9bc0d7d6c
EBUILD openssl-1.0.1g.ebuild 10756 SHA256 9191ccb65b3c9cc0f60d364c592bf9d27ea557e3e034c304383c0f6453ed7e16 SHA512 e0923143504487ad5376c76fa4526b5e1f25cdeefcf11e38e945263e61ec9b85276a4dd397d70719a05fcdf797600ed3e1739de1a5a14880587c85b7de2fb75c WHIRLPOOL aea760e43b9e4f5437fd3cfdbd2ea4e708c976246e505bd5142747eac170270f3a9f95f237d32a681ec7e2fb124b010fa623bc412de447a75185d6ed72efff0a
@@ -79,3 +80,4 @@ EBUILD openssl-1.0.2d.ebuild 12045 SHA256 4897afa0324b2936494469018dccc4ead8a31b
EBUILD openssl-1.0.2e.ebuild 11509 SHA256 e0de8de0ee0e4ce710e6cd44330fb37520b420a58e668d85cfe13c49e92e8fef SHA512 ac64e9cb114c543c04a36030f04b525ad4fbea51fa914a0d04c085fcde70711b9b61bfd886d542d4608e3bf28351615fef4d9affa5d75c8a3e3396b74d77cb8f WHIRLPOOL fbdb28cb30d63041de835c3a4e92fffdf05bf22e3179b0c8f667ca226fe2a2f0951818804e4bee95f58c03b77e6b51ec50d7d5c3f30399a8686ad1e5bb3136bf
EBUILD openssl-1.0.2f.ebuild 11441 SHA256 cdeaea9a3532c6dbef93b9294b2ebd9709647a9a45240900d93d29104cc2caf9 SHA512 134f1a9ea53477e32377ed31f1bbabab2d53e8aeb8846823d49bf841ce3b1144933a77caee3aef1c469bd38d8b7a58c70fb807f879cdcbe51f3d6242d1a720e6 WHIRLPOOL f3d4a1b7ccc030db57efbd73b6681c1e2f460c634caff04d6f9d82d1ee7fcd5a5eb9eeb19818482d2c4c671f1920dd58ad6f222568d3be7515b90fe02e885845
EBUILD openssl-1.0.2g-r2.ebuild 11282 SHA256 5bafec9f441d75755169c26af627c0fc64b3f019f85fe872a0f1a22fa4f904c0 SHA512 aff7572e092afe00fc8a48bda32fe7ea8d9d2ef39922e3b16e3310534462b99a0203a9c2e006a3edd846e5d44af39ab1cd15f3599e57c714709229fbb856f5fc WHIRLPOOL 15feeeb2977ca3b11fdee6e19acb1edd12d9de556a01538032d690f1e3402ea2a6ba9131b78a8d51140992753309a213b3401a0aae48f1e1655c224dbe21611f
+EBUILD openssl-1.0.2h.ebuild 11291 SHA256 648eb556bc3282022a5d35c4e22d0b59e0d76dcc90a22dbe1e6bd7b9bd1f584a SHA512 1365ed065ef313dc565730dd534a738f0221fbb32f10c28658c55706cdf9279530344be053c1106a91f9986c364a4f1ea809d1db43973838809e3397083a3778 WHIRLPOOL 507831af7adc0e012f1155b4658dff3b09fad31dcab01362ca1aa3f90812815d6fd186055a0611df1bc3a91bf1c9bdbc5b280acd48d799c43ed2a74c8c3238ae
diff --git a/dev-libs/openssl/openssl-1.0.2h.ebuild b/dev-libs/openssl/openssl-1.0.2h.ebuild
new file mode 100644
index 00000000..92109a07
--- /dev/null
+++ b/dev-libs/openssl/openssl-1.0.2h.ebuild
@@ -0,0 +1,325 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id: 1a09d5ead4884093f1cad79221efc75b44c0cd0e $
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs multilib multilib-minimal
+
+MY_P=${P/_/-}
+DESCRIPTION="full-strength general purpose cryptography library (including SSL and TLS)"
+HOMEPAGE="http://www.openssl.org/"
+SRC_URI="mirror://openssl/source/${MY_P}.tar.gz"
+
+LICENSE="openssl"
+# subslot set to 1.0.2g version as this is the first release without SSLv2
+# support and thus breaks nearly every openssl consumer (see bug #575548)
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 hppa ~ia64 ~m68k ~mips ~ppc ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~arm-linux ~x86-linux"
+IUSE="+asm bindist gmp kerberos rfc3779 sctp cpu_flags_x86_sse2 static-libs test +tls-heartbeat vanilla zlib"
+RESTRICT="!bindist? ( bindist )"
+
+RDEPEND=">=app-misc/c_rehash-1.7-r1
+ gmp? ( >=dev-libs/gmp-5.1.3-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
+ zlib? ( >=sys-libs/zlib-1.2.8-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
+ kerberos? ( >=app-crypt/mit-krb5-1.11.4[${MULTILIB_USEDEP}] )"
+DEPEND="${RDEPEND}
+ >=dev-lang/perl-5
+ sctp? ( >=net-misc/lksctp-tools-1.0.12 )
+ test? (
+ sys-apps/diffutils
+ sys-devel/bc
+ )"
+PDEPEND="app-misc/ca-certificates"
+
+S="${WORKDIR}/${MY_P}"
+
+MULTILIB_WRAPPED_HEADERS=(
+ usr/include/openssl/opensslconf.h
+)
+
+src_prepare() {
+ # keep this in sync with app-misc/c_rehash
+ SSL_CNF_DIR="/etc/ssl"
+
+ # Make sure we only ever touch Makefile.org and avoid patching a file
+ # that gets blown away anyways by the Configure script in src_configure
+ rm -f Makefile
+
+ if ! use vanilla ; then
+ epatch "${FILESDIR}"/${PN}-1.0.0a-ldflags.patch #327421
+ epatch "${FILESDIR}"/${PN}-1.0.0d-windres.patch #373743
+ epatch "${FILESDIR}"/${PN}-1.0.2g-parallel-build.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2a-parallel-obj-headers.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2a-parallel-install-dirs.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2a-parallel-symlinking.patch #545028
+ epatch "${FILESDIR}"/${PN}-1.0.2-ipv6.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2a-x32-asm.patch #542618
+ epatch "${FILESDIR}"/${PN}-1.0.1p-default-source.patch #554338
+
+ epatch_user #332661
+ fi
+
+ # disable fips in the build
+ # make sure the man pages are suffixed #302165
+ # don't bother building man pages if they're disabled
+ sed -i \
+ -e '/DIRS/s: fips : :g' \
+ -e '/^MANSUFFIX/s:=.*:=ssl:' \
+ -e '/^MAKEDEPPROG/s:=.*:=$(CC):' \
+ -e $(has noman FEATURES \
+ && echo '/^install:/s:install_docs::' \
+ || echo '/^MANDIR=/s:=.*:='${EPREFIX}'/usr/share/man:') \
+ Makefile.org \
+ || die
+ # show the actual commands in the log
+ sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
+
+ # avoid using /bin/sh because it's fragile on some platforms (Solaris)
+ sed -i -e "/SHELL=/s:=.*$:=${CONFIG_SHELL:-${BASH}}:" Makefile.org || die
+ sed -i -e "1a\SHELL=${CONFIG_SHELL:-${BASH}}" Makefile.shared || die
+
+ epatch "${FILESDIR}"/${PN}-0.9.8g-engines-installnames.patch
+ epatch "${FILESDIR}"/${PN}-1.0.0a-interix.patch
+ epatch "${FILESDIR}"/${PN}-1.0.0a-mint.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2a-aix-soname.patch # like libtool
+ epatch "${FILESDIR}"/${PN}-1.0.0b-darwin-bundle-compile-fix.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2-gethostbyname2-solaris.patch
+ if [[ ${CHOST} == *-interix* ]] ; then
+ sed -i -e 's/-Wl,-soname=/-Wl,-h -Wl,/' Makefile.shared || die
+ fi
+
+ # again, this windows patch should not do any harm to others, but
+ # header files are copied instead of linked now, so leave it conditional.
+ [[ ${CHOST} == *-winnt* ]] && epatch "${FILESDIR}"/${PN}-0.9.8k-winnt.patch
+
+ # remove -arch for darwin
+ sed -i '/^"darwin/s,-arch [^ ]\+,,g' Configure || die
+
+ # since we're forcing $(CC) as makedep anyway, just fix
+ # the conditional as always-on
+ # helps clang (#417795), and versioned gcc (#499818)
+ sed -i 's/expr.*MAKEDEPEND.*;/true;/' util/domd || die
+
+ # quiet out unknown driver argument warnings since openssl
+ # doesn't have well-split CFLAGS and we're making it even worse
+ # and 'make depend' uses -Werror for added fun (#417795 again)
+ #[[ ${CC} == *clang* ]] && append-flags -Qunused-arguments
+ #append-flags $(test-flags-CC -Qunused-arguments)
+ append-flags $(test-flags-CC -Wno-error=unused-command-line-argument)
+
+ # allow openssl to be cross-compiled
+ cp "${FILESDIR}"/gentoo.config-1.0.2 gentoo.config || die
+ chmod a+rx gentoo.config
+
+ append-flags -fno-strict-aliasing
+ append-flags $(test-flags-CC -Wa,--noexecstack)
+ append-cppflags -DOPENSSL_NO_BUF_FREELISTS
+
+ # avoid waiting on terminal input forever when spitting
+ # 64bit warning message.
+ [[ ${CHOST} == *-hpux* ]] && sed -i -e 's,stty,true,g' -e 's,read waste,true,g' config
+
+ # Upstream insists that the GNU assembler fails, so insist on calling the
+ # vendor assembler. However, I find otherwise. At least on Solaris-9
+ # --darkside (26 Aug 2008)
+ if [[ ${CHOST} == sparc-sun-solaris2.9 ]]; then
+ sed -i -e "s:/usr/ccs/bin/::" crypto/bn/Makefile || die "sed failed"
+ fi
+
+ # type -P required on platforms where perl is not installed
+ # in the same prefix (prefix-chaining).
+ sed -i '1s,^:$,#!'${EPREFIX}'/usr/bin/perl,' Configure || die #141906
+
+ # The config script does stupid stuff to prompt the user. Kill it.
+ sed -i '/stty -icanon min 0 time 50; read waste/d' config || die
+ ./config -t --test-sanity || die "Sanity checks failed"
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ unset APPS #197996
+ unset SCRIPTS #312551
+ unset CROSS_COMPILE #311473
+
+ tc-export CC AR RANLIB RC
+
+ # Clean out patent-or-otherwise-encumbered code
+ # Camellia: Royalty Free http://en.wikipedia.org/wiki/Camellia_(cipher)
+ # IDEA: Expired http://en.wikipedia.org/wiki/International_Data_Encryption_Algorithm
+ # EC: ????????? ??/??/2015 http://en.wikipedia.org/wiki/Elliptic_Curve_Cryptography
+ # MDC2: Expired http://en.wikipedia.org/wiki/MDC-2
+ # RC5: Expired http://en.wikipedia.org/wiki/RC5
+
+ use_ssl() { usex $1 "enable-${2:-$1}" "no-${2:-$1}" " ${*:3}" ; }
+ echoit() { echo "$@" ; "$@" ; }
+
+ local krb5=$(has_version app-crypt/mit-krb5 && echo "MIT" || echo "Heimdal")
+
+ case $CHOST in
+ sparc*-sun-solaris*)
+ # openssl doesn't grok this setup, and guesses
+ # the architecture wrong causing segfaults,
+ # just disable asm for now
+ # FIXME: I need to report this upstream
+ confopts="${confopts} no-asm"
+ ;;
+ *-aix*)
+ # symbols in asm file aren't exported for yet unknown reason
+ confopts="${confopts} no-asm"
+ ;;
+ esac
+
+ # See if our toolchain supports __uint128_t. If so, it's 64bit
+ # friendly and can use the nicely optimized code paths. #460790
+ local ec_nistp_64_gcc_128
+ # Disable it for now though #469976
+ #if ! use bindist ; then
+ # echo "__uint128_t i;" > "${T}"/128.c
+ # if ${CC} ${CFLAGS} -c "${T}"/128.c -o /dev/null >&/dev/null ; then
+ # ec_nistp_64_gcc_128="enable-ec_nistp_64_gcc_128"
+ # fi
+ #fi
+
+ local sslout=$(./gentoo.config)
+ einfo "Use configuration ${sslout:-(openssl knows best)}"
+ local config="Configure"
+ [[ -z ${sslout} ]] && config="config"
+
+ echoit \
+ ./${config} \
+ ${sslout} \
+ $(use cpu_flags_x86_sse2 || echo "no-sse2") \
+ enable-camellia \
+ $(use_ssl !bindist ec) \
+ ${ec_nistp_64_gcc_128} \
+ enable-idea \
+ enable-mdc2 \
+ enable-rc5 \
+ enable-tlsext \
+ enable-ssl2 \
+ $(use_ssl asm) \
+ $(use_ssl gmp gmp -lgmp) \
+ $(use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
+ $(use_ssl rfc3779) \
+ $(use_ssl sctp) \
+ $(use_ssl tls-heartbeat heartbeats) \
+ $(use_ssl zlib) \
+ --prefix="${EPREFIX}"/usr \
+ --openssldir="${EPREFIX}"${SSL_CNF_DIR} \
+ --libdir=$(get_libdir) \
+ shared threads ${confopts} \
+ || die
+
+ if [[ ${CHOST} == i?86*-*-linux* || ${CHOST} == i?86*-*-freebsd* ]]; then
+ # does not compile without optimization on x86-linux and x86-fbsd
+ filter-flags -O0
+ is-flagq -O* || append-flags -O1
+ fi
+
+ # Clean out hardcoded flags that openssl uses
+ local CFLAG=$(grep ^CFLAG= Makefile | LC_ALL=C sed \
+ -e 's:^CFLAG=::' \
+ -e 's:-fomit-frame-pointer ::g' \
+ -e 's:-O[0-9] ::g' \
+ -e 's:-march=[-a-z0-9]* ::g' \
+ -e 's:-mcpu=[-a-z0-9]* ::g' \
+ -e 's:-m[a-z0-9]* ::g' \
+ )
+ # CFLAGS can contain ':', e.g. MIPSpro
+ sed -i \
+ -e "/^CFLAG/s|=.*|=${CFLAG} ${CFLAGS}|" \
+ -e "/^SHARED_LDFLAGS=/s|$| ${LDFLAGS}|" \
+ Makefile || die
+}
+
+multilib_src_compile() {
+ if [[ ${CHOST} == *-winnt* ]]; then
+ ( cd fips && emake -j1 links PERL=$(type -P perl) ) || die "make links in fips failed"
+ fi
+
+ # depend is needed to use $confopts; it also doesn't matter
+ # that it's -j1 as the code itself serializes subdirs
+ emake -j1 depend
+ emake all
+ # rehash is needed to prep the certs/ dir; do this
+ # separately to avoid parallel build issues.
+ emake rehash
+}
+
+multilib_src_test() {
+ emake -j1 test
+}
+
+multilib_src_install() {
+ emake INSTALL_PREFIX="${D}" install
+}
+
+multilib_src_install_all() {
+ # openssl installs perl version of c_rehash by default, but
+ # we provide a shell version via app-misc/c_rehash
+ rm "${ED}"/usr/bin/c_rehash || die
+
+ dodoc CHANGES* FAQ NEWS README doc/*.txt doc/c-indentation.el
+ dohtml -r doc/*
+ use rfc3779 && dodoc engines/ccgost/README.gost
+
+ # At least wget (>1.15?) is unhappy if any non-certificate appears
+ # in ${SSL_CNF_DIR}/certs...
+ dodoc certs/README.* && rm certs/README.*
+
+ # This is crappy in that the static archives are still built even
+ # when USE=static-libs. But this is due to a failing in the openssl
+ # build system: the static archives are built as PIC all the time.
+ # Only way around this would be to manually configure+compile openssl
+ # twice; once with shared lib support enabled and once without.
+ use static-libs || rm -f "${ED}"/usr/lib*/lib*.a
+
+ # create the certs directory
+ dodir ${SSL_CNF_DIR}/certs
+ cp -RP certs/* "${ED}"${SSL_CNF_DIR}/certs/ || die
+ rm -r "${ED}"${SSL_CNF_DIR}/certs/{demo,expired}
+
+ # Namespace openssl programs to prevent conflicts with other man pages
+ cd "${ED}"/usr/share/man
+ local m d s
+ for m in $(find . -type f | xargs grep -L '#include') ; do
+ d=${m%/*} ; d=${d#./} ; m=${m##*/}
+ [[ ${m} == openssl.1* ]] && continue
+ [[ -n $(find -L ${d} -type l) ]] && die "erp, broken links already!"
+ mv ${d}/{,ssl-}${m}
+ # fix up references to renamed man pages
+ sed -i '/^[.]SH "SEE ALSO"/,/^[.]/s:\([^(, ]*(1)\):ssl-\1:g' ${d}/ssl-${m}
+ ln -s ssl-${m} ${d}/openssl-${m}
+ # locate any symlinks that point to this man page ... we assume
+ # that any broken links are due to the above renaming
+ for s in $(find -L ${d} -type l) ; do
+ s=${s##*/}
+ rm -f ${d}/${s}
+ ln -s ssl-${m} ${d}/ssl-${s}
+ ln -s ssl-${s} ${d}/openssl-${s}
+ done
+ done
+ [[ -n $(find -L ${d} -type l) ]] && die "broken manpage links found :("
+
+ dodir /etc/sandbox.d #254521
+ echo 'SANDBOX_PREDICT="/dev/crypto"' > "${ED}"/etc/sandbox.d/10openssl
+
+ diropts -m0700
+ keepdir ${SSL_CNF_DIR}/private
+}
+
+pkg_preinst() {
+ has_version ${CATEGORY}/${PN}:0.9.8 && return 0
+ preserve_old_lib /usr/$(get_libdir)/lib{crypto,ssl}$(get_libname 0.9.8)
+}
+
+pkg_postinst() {
+ ebegin "Running 'c_rehash ${EROOT%/}${SSL_CNF_DIR}/certs/' to rebuild hashes #333069"
+ c_rehash "${EROOT%/}${SSL_CNF_DIR}/certs" >/dev/null
+ eend $?
+
+ has_version ${CATEGORY}/${PN}:0.9.8 && return 0
+ preserve_old_lib_notify /usr/$(get_libdir)/lib{crypto,ssl}$(get_libname 0.9.8)
+}