summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/gtk+/Manifest2
-rw-r--r--x11-libs/gtk+/files/settings.ini4
-rw-r--r--x11-libs/gtk+/gtk+-9999-r1.ebuild172
-rw-r--r--x11-libs/gtksourceview/Manifest2
-rw-r--r--x11-libs/gtksourceview/files/2.0/gentoo.lang111
-rw-r--r--x11-libs/gtksourceview/gtksourceview-9999-r1.ebuild66
-rw-r--r--x11-libs/libcryptui/Manifest1
-rw-r--r--x11-libs/libcryptui/libcryptui-9999-r1.ebuild65
8 files changed, 0 insertions, 423 deletions
diff --git a/x11-libs/gtk+/Manifest b/x11-libs/gtk+/Manifest
deleted file mode 100644
index 6efd160b..00000000
--- a/x11-libs/gtk+/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-AUX settings.ini 96 RMD160 ff8d7e28f097820b15ea1d2168d9405db1a5707b SHA1 92c3120655ba14f163846a22d5c94fa50b0eb437 SHA256 a42c86c26b5bfa0da806961e28cdff21da6e2f7c35febf67c67d7f2667658163
-EBUILD gtk+-9999-r1.ebuild 4734 RMD160 bbe3b5ad0c7cb136da60233c5f1ee88cedc71d9e SHA1 438f6886d43a2038fe21c327c75b38ac728245df SHA256 5266b27fa9f001cdd5f952be463421a643e3718fdfb7530a7d04dce4935ea97d
diff --git a/x11-libs/gtk+/files/settings.ini b/x11-libs/gtk+/files/settings.ini
deleted file mode 100644
index a65c0a81..00000000
--- a/x11-libs/gtk+/files/settings.ini
+++ /dev/null
@@ -1,4 +0,0 @@
-[Settings]
-gtk-theme-name = Adwaita
-gtk-icon-theme-name = gnome
-gtk-cursor-theme-name = Adwaita
diff --git a/x11-libs/gtk+/gtk+-9999-r1.ebuild b/x11-libs/gtk+/gtk+-9999-r1.ebuild
deleted file mode 100644
index 79d6da08..00000000
--- a/x11-libs/gtk+/gtk+-9999-r1.ebuild
+++ /dev/null
@@ -1,172 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-
-inherit eutils flag-o-matic gnome2-live libtool virtualx
-
-DESCRIPTION="Gimp ToolKit +"
-HOMEPAGE="http://www.gtk.org/"
-
-LICENSE="LGPL-2"
-SLOT="3"
-IUSE="aqua broadway colord cups debug doc examples +introspection packagekit test vim-syntax xinerama"
-KEYWORDS=""
-
-COMMON_DEPEND="!aqua? (
- x11-libs/libXrender
- x11-libs/libX11
- x11-libs/libXi
- x11-libs/libXt
- x11-libs/libXext
- >=x11-libs/libXrandr-1.3
- x11-libs/libXcursor
- x11-libs/libXfixes
- x11-libs/libXcomposite
- x11-libs/libXdamage
- >=x11-libs/cairo-1.10.0[X,svg]
- >=x11-libs/gdk-pixbuf-2.23.5:2[X,introspection?]
- )
- aqua? (
- >=x11-libs/cairo-1.10.0[aqua,svg]
- >=x11-libs/gdk-pixbuf-2.23.5:2[introspection?]
- )
- xinerama? ( x11-libs/libXinerama )
- >=dev-libs/glib-2.31
- >=x11-libs/pango-1.29.0[introspection?]
- >=dev-libs/atk-2.1.5[introspection?]
- >=x11-libs/gtk+-2.24:2
- media-libs/fontconfig
- x11-misc/shared-mime-info
- colord? ( >=x11-misc/colord-0.1.9 )
- cups? ( net-print/cups )
- introspection? ( >=dev-libs/gobject-introspection-0.10.1 )"
-DEPEND="${COMMON_DEPEND}
- >=dev-util/pkgconfig-0.9
- !aqua? (
- x11-proto/xextproto
- x11-proto/xproto
- x11-proto/inputproto
- x11-proto/damageproto
- )
- xinerama? ( x11-proto/xineramaproto )
- >=dev-util/gtk-doc-am-1.11
- doc? (
- >=dev-util/gtk-doc-1.11
- ~app-text/docbook-xml-dtd-4.1.2 )
- test? (
- media-fonts/font-misc-misc
- media-fonts/font-cursor-misc )"
-RDEPEND="${COMMON_DEPEND}
- packagekit? ( app-admin/packagekit-base )"
-PDEPEND="vim-syntax? ( app-vim/gtk-syntax )"
-
-strip_builddir() {
- local rule=$1
- shift
- local directory=$1
- shift
- sed -e "s/^\(${rule} =.*\)${directory}\(.*\)$/\1\2/" -i $@ \
- || die "Could not strip director ${directory} from build."
-}
-
-src_prepare() {
- # -O3 and company cause random crashes in applications. Bug #133469
- replace-flags -O3 -O2
- strip-flags
-
- # Non-working test in gentoo's env
- sed 's:\(g_test_add_func ("/ui-tests/keys-events.*\):/*\1*/:g' \
- -i gtk/tests/testing.c || die "sed 1 failed"
- sed '\%/recent-manager/add%,/recent_manager_purge/ d' \
- -i gtk/tests/recentmanager.c || die "sed 2 failed"
-
- if ! use test; then
- # don't waste time building tests
- strip_builddir SRC_SUBDIRS tests Makefile.am
- [[ ${PV} != 9999 ]] && strip_builddir SRC_SUBDIRS tests Makefile.in
- fi
-
- if ! use examples; then
- # don't waste time building demos
- strip_builddir SRC_SUBDIRS demos Makefile.am
- [[ ${PV} != 9999 ]] && strip_builddir SRC_SUBDIRS demos Makefile.in
- fi
-
- gnome2_src_prepare
-}
-
-src_configure() {
- local myconf="$(use_enable doc gtk-doc)
- $(use_enable xinerama)
- $(use_enable packagekit)
- $(use_enable cups cups auto)
- $(use_enable colord)
- $(use_enable introspection)
- $(use_enable broadway broadway-backend)
- --disable-packagekit
- --disable-papi
- --enable-gtk2-dependency"
-
- # XXX: Maybe with multi-backend we should enable x11 all the time?
- if use aqua; then
- myconf="${myconf} --enable-quartz-backend --disable-xinput"
- else
- myconf="${myconf} --enable-x11-backend --enable-xinput"
- fi
-
- # Passing --disable-debug is not recommended for production use
- use debug && myconf="${myconf} --enable-debug=yes"
-
- # need libdir here to avoid a double slash in a path that libtool doesn't
- # grok so well during install (// between $EPREFIX and usr ...)
- econf --libdir="${EPREFIX}/usr/$(get_libdir)" ${myconf}
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
- # Exporting HOME fixes tests using XDG directories spec since all defaults
- # are based on $HOME. It is also backward compatible with functions not
- # yet ported to this spec.
- XDG_DATA_HOME="${T}" HOME="${T}" Xemake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
-
- insinto /etc/gtk-3.0
- doins "${FILESDIR}"/settings.ini
-
- dodoc AUTHORS ChangeLog* HACKING NEWS* README*
-
- # Remove unneeded *.la files
- find "${ED}" -name "*.la" -delete
-
- # add -framework Carbon to the .pc files
- use aqua && for i in gtk+-3.0.pc gtk+-quartz-3.0.pc gtk+-unix-print-3.0.pc; do
- sed -i -e "s:Libs\: :Libs\: -framework Carbon :" "${ED}"usr/$(get_libdir)/pkgconfig/$i || die "sed failed"
- done
-}
-
-pkg_preinst() {
- gnome2_schemas_savelist
-}
-
-pkg_postinst() {
- gnome2_schemas_update
-
- local GTK3_MODDIR="${EROOT}usr/$(get_libdir)/gtk-3.0/3.0.0"
- gtk-query-immodules-3.0 > "${GTK3_MODDIR}/immodules.cache" \
- || ewarn "Failed to run gtk-query-immodules-3.0"
-
- if ! has_version "app-text/evince"; then
- elog "Please install app-text/evince for print preview functionality."
- elog "Alternatively, check \"gtk-print-preview-command\" documentation and"
- elog "add it to your settings.ini file."
- fi
-}
-
-pkg_postrm() {
- gnome2_schemas_update --uninstall
-}
diff --git a/x11-libs/gtksourceview/Manifest b/x11-libs/gtksourceview/Manifest
deleted file mode 100644
index fe20291b..00000000
--- a/x11-libs/gtksourceview/Manifest
+++ /dev/null
@@ -1,2 +0,0 @@
-AUX 2.0/gentoo.lang 3910 RMD160 43b51212ec2787b9d95e9d4f512342b920d6c355 SHA1 22ce79797f654f1f7b6894de8cb12bbdcdf70bee SHA256 fcb5133892038174826d9ee1a720ec7204f3842c7bd3e9aabf0532b408e663d1
-EBUILD gtksourceview-9999-r1.ebuild 1724 RMD160 d1fe703537b4b7301249cdc7de9f4855bb1f9815 SHA1 7d6e140e147e365132e7d4a62ef55725506530da SHA256 faa6df6e61d88e0f85aaa776c7b9aae17734a01a2d7da59f1e0c7e177bc3e520
diff --git a/x11-libs/gtksourceview/files/2.0/gentoo.lang b/x11-libs/gtksourceview/files/2.0/gentoo.lang
deleted file mode 100644
index f1e0660c..00000000
--- a/x11-libs/gtksourceview/files/2.0/gentoo.lang
+++ /dev/null
@@ -1,111 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-
-<!--
- GtkSourceView syntax highlight for Gentoo-specific files
-
- Originally written for gtksourceview-1.x by:
- Leonardo Ferreira Fontenelle <leo.fontenelle@gmail.com>, 2006.
- Rewritten for gtksourceview-2 by:
- Rene 'Necoro' Neumann <necoro@necoro.net>, 2007
-
- Distributed under the same license(s) as gtksourceview.
-
- TODO:
- - do not highlight "enable" in the configure options
- - perhaps highlight portage variables and portage functions different
-
--->
-
-<language name="gentoo" id="gentoo" version="2.0" _section="Scripts">
- <metadata>
- <property name="globs">*.ebuild;*.eclass</property>
- <property name="line-comment-start">#</property>
- </metadata>
-
- <styles>
- <style id="variable" _name="Portage variables" map-to="def:builtin" />
- <style id="command" _name="Portage command" map-to="def:type" />
- <style id="function" _name="Portage function" map-to="def:function" />
- <style id="string" _name="String" map-to="def:string" />
- </styles>
-
- <definitions>
-
- <!-- rewrite shell string to show highlighted variables -->
- <context id="string" style-ref="def:string">
- <start>"</start>
- <end>"</end>
- <include>
- <context ref="def:escape"/>
- <context ref="def:line-continue"/>
- <context ref="sh:variable"/>
- </include>
- </context>
-
- <context id="string-2" style-ref="def:string">
- <start>'</start>
- <end>'</end>
- <include>
- <context ref="def:escape"/>
- <context ref="def:line-continue"/>
- <context ref="sh:variable"/>
- </include>
- </context>
-
- <!-- subprograms:
- - $(..) is not supported currently in the normal sh.lang
- - `...` is interpreted as string - I think the subshell behavior is more acurate -->
- <context id="subprogram">
- <start>\$\(</start>
- <end>\)</end>
- <include>
- <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
- <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
- <context ref="gentoo"/>
- </include>
- </context>
-
- <context id="subprogram-2">
- <start>`</start>
- <end>`</end>
- <include>
- <context sub-pattern="0" where="start" style-ref="sh:keyword"/>
- <context sub-pattern="0" where="end" style-ref="sh:keyword"/>
- <context ref="gentoo"/>
- </include>
- </context>
-
- <!-- portage variables - currently unused -->
- <context id="portvars" style-ref="variable">
- <match>\b((ARCH|HOMEPAGE|DESCRIPTION|IUSE|SRC_URI|LICENSE|SLOT|KEYWORDS|FILESDIR|WORKDIR|(P|R)?DEPEND|PROVIDE|DISTDIR|RESTRICT|USERLAND)|(S|D|T|PV|PF|P|PN|A)|C(XX)?FLAGS|LDFLAGS|C(HOST|TARGET|BUILD))\b</match>
- </context>
-
- <!-- portage functions - currently unused -->
- <context id="portfuncs" style-ref="function">
- <match>^(src_(unpack|compile|install|test)|pkg_(config|nofetch|setup|(pre|post)(inst|rm)))</match>
- </context>
-
- <!-- extra portage commands -->
- <context id="portcmds" style-ref="command">
- <match>\b(e(begin|end|conf|install|make|warn|infon?|error|patch)|die|use(_(with|enable))?|inherit|has|(has|best)_version|unpack|(do|new)(ins|s?bin|doc|lib(|\.so|\.a)|man|info|exe|initd|confd|envd|pam|menu|icon)|do(python|sed|dir|hard|sym|html|jar|mo)|keepdir|prepall(|docs|info|man|strip)|prep(info|lib|lib\.(so|a)|man|strip)|(|doc|ins|exe)into|f(owners|perms)|(exe|ins|dir)opts)\b</match>
- </context>
-
- <context id="built-in-command">
- <include> <!-- do not include "sh:built-in-command" as it is replaced down there - which would lead to an endless loop -->
- <context ref="sh:built-in-command-1" />
- <context ref="sh:built-in-command-2" />
- <context ref="portcmds" />
- </include>
- </context>
-
- <!-- gentoo is just a shell with the replacements -->
- <replace id="sh:built-in-command" ref="built-in-command" />
- <replace id="sh:backtick-subshell" ref="subprogram-2" />
- <context id="gentoo">
- <include>
- <context ref="subprogram"/>
- <context ref="sh:sh"/>
- </include>
- </context>
- </definitions>
-</language>
diff --git a/x11-libs/gtksourceview/gtksourceview-9999-r1.ebuild b/x11-libs/gtksourceview/gtksourceview-9999-r1.ebuild
deleted file mode 100644
index c082d450..00000000
--- a/x11-libs/gtksourceview/gtksourceview-9999-r1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-libs/gtksourceview/gtksourceview-3.0.4.ebuild,v 1.1 2011/06/20 11:45:03 pacho Exp $
-
-EAPI="4"
-GCONF_DEBUG="no"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2 virtualx
-if [[ ${PV} = 9999 ]]; then
- inherit gnome2-live
-fi
-
-DESCRIPTION="A text widget implementing syntax highlighting and other features"
-HOMEPAGE="http://projects.gnome.org/gtksourceview/"
-
-LICENSE="GPL-2"
-SLOT="3.0"
-IUSE="doc glade +introspection"
-if [[ ${PV} = 9999 ]]; then
- KEYWORDS=""
-else
- KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x86-solaris"
-fi
-
-# Note: has native OSX support, prefix teams, attack!
-RDEPEND=">=x11-libs/gtk+-3.0:3[introspection?]
- >=dev-libs/libxml2-2.6:2
- >=dev-libs/glib-2.28:2
- glade? ( >=dev-util/glade-3.9:3.10 )
- introspection? ( >=dev-libs/gobject-introspection-0.9.0 )"
-DEPEND="${RDEPEND}
- >=sys-devel/gettext-0.17
- >=dev-util/intltool-0.40
- >=dev-util/pkgconfig-0.9
- doc? ( >=dev-util/gtk-doc-1.11 )"
-
-pkg_setup() {
- DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README"
- G2CONF="${G2CONF}
- --disable-deprecations
- --disable-maintainer-mode
- --enable-providers
- $(use_enable glade glade-catalog)
- $(use_enable introspection)"
-}
-
-src_prepare() {
- # Skip broken test until upstream bug #621383 is solved
- sed -e "/guess-language/d" \
- -e "/get-language/d" \
- -i tests/test-languagemanager.c || die
-
- gnome2_src_prepare
-}
-
-src_test() {
- Xemake check
-}
-
-src_install() {
- gnome2_src_install
-
- insinto /usr/share/${PN}-3.0/language-specs
- doins "${FILESDIR}"/2.0/gentoo.lang
-}
diff --git a/x11-libs/libcryptui/Manifest b/x11-libs/libcryptui/Manifest
deleted file mode 100644
index ca2d9892..00000000
--- a/x11-libs/libcryptui/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-EBUILD libcryptui-9999-r1.ebuild 1505 RMD160 0ed20c90d48118746cf25976ab441b587189379a SHA1 c66a869465977ceb1e73634aa77c4231b008e283 SHA256 2fcf0a7ead771e922b40fca1e42a2c4e7244a5a3cdf61523dcdff5b73d39de77
diff --git a/x11-libs/libcryptui/libcryptui-9999-r1.ebuild b/x11-libs/libcryptui/libcryptui-9999-r1.ebuild
deleted file mode 100644
index 3a91bffd..00000000
--- a/x11-libs/libcryptui/libcryptui-9999-r1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI="4"
-GCONF_DEBUG="yes"
-GNOME2_LA_PUNT="yes"
-
-inherit gnome2-live
-
-DESCRIPTION="User interface components for OpenPGP"
-HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
-
-LICENSE="GPL-2 LGPL-2"
-SLOT="0"
-IUSE="debug doc +introspection libnotify test"
-KEYWORDS=""
-
-# Pull in libnotify-0.7 because it's controlled via an automagic ifdef
-COMMON_DEPEND="
- >=dev-libs/glib-2.10:2
- >=x11-libs/gtk+-2.90.0:3[introspection?]
- >=dev-libs/dbus-glib-0.72
- >=gnome-base/gnome-keyring-2.91.2
-
- >=app-crypt/gpgme-1
- || (
- =app-crypt/gnupg-2.0*
- =app-crypt/gnupg-1.4* )
-
- introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
- libnotify? ( >=x11-libs/libnotify-0.7.0 )
-"
-DEPEND="${COMMON_DEPEND}
- sys-devel/gettext
- >=app-text/scrollkeeper-0.3
- >=dev-util/pkgconfig-0.20
- >=dev-util/intltool-0.35
- doc? ( >=dev-util/gtk-doc-1.9 )
-"
-# Before 3.1.4, libcryptui was part of seahorse
-RDEPEND="${COMMON_DEPEND}
- !<app-crypt/seahorse-3.1.4
-"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --disable-static
- --disable-scrollkeeper
- --disable-update-mime-database
- $(use_enable debug)
- $(use_enable introspection)
- $(use_enable libnotify)
- $(use_enable test tests)"
- DOCS="AUTHORS ChangeLog NEWS README"
-}
-
-src_prepare() {
- # FIXME: Do not mess with CFLAGS with USE="debug"
- sed -e '/CFLAGS="$CFLAGS -g -O0/d' \
- -e 's/-Werror//' \
- -i configure.ac || die "sed failed"
-
- gnome2_src_prepare
-}