summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/idea-community/idea-community-11.0.2.111.277.ebuild')
-rw-r--r--dev-util/idea-community/idea-community-11.0.2.111.277.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-util/idea-community/idea-community-11.0.2.111.277.ebuild b/dev-util/idea-community/idea-community-11.0.2.111.277.ebuild
deleted file mode 100644
index 9fd6f74a..00000000
--- a/dev-util/idea-community/idea-community-11.0.2.111.277.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-inherit eutils versionator
-
-SLOT="$(get_major_version)"
-RDEPEND=">=virtual/jdk-1.6"
-
-MY_PV="$(get_version_component_range 4-5)"
-MY_PN="idea"
-
-RESTRICT="strip"
-QA_TEXTRELS="opt/${P}/bin/libbreakgen.so"
-
-DESCRIPTION="IntelliJ IDEA is an intelligent Java IDE"
-HOMEPAGE="http://jetbrains.com/idea/"
-SRC_URI="http://download.jetbrains.com/${MY_PN}/${MY_PN}IC-$(get_version_component_range 1-3).tar.gz"
-LICENSE="IntelliJ-IDEA"
-IUSE=""
-KEYWORDS="~x86 ~amd64"
-S="${WORKDIR}/${MY_PN}-IC-${MY_PV}"
-
-RDEPEND="!dev-util/idea-ultimate"
-
-src_install() {
- local dir="/opt/${P}"
- insinto "${dir}"
- doins -r *
- fperms 755 "${dir}/bin/${MY_PN}.sh"
- local exe=${MY_PN}-${SLOT}
- local icon=${exe}.png
- newicon "bin/${MY_PN}_CE32.png" ${icon}
- dodir /usr/bin
- make_wrapper "$exe" "/opt/${P}/bin/${MY_PN}.sh"
- make_desktop_entry ${exe} "IntelliJ IDEA ${PV}" ${icon} "Development;IDE"
-}