summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'app-editors/gedit/gedit-2.31.5.ebuild')
-rw-r--r--app-editors/gedit/gedit-2.31.5.ebuild53
1 files changed, 0 insertions, 53 deletions
diff --git a/app-editors/gedit/gedit-2.31.5.ebuild b/app-editors/gedit/gedit-2.31.5.ebuild
deleted file mode 100644
index 7912d012..00000000
--- a/app-editors/gedit/gedit-2.31.5.ebuild
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=3
-inherit eutils gnome2
-
-DESCRIPTION="A text editor for the GNOME desktop"
-HOMEPAGE="http://www.gnome.org/"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc introspection spell"
-
-RDEPEND=">=x11-libs/libSM-1.0
- >=dev-libs/libxml2-2.5.0
- >=dev-libs/glib-2.25.10
- >=x11-libs/gtk+-2.90:3[introspection?]
- >=x11-libs/gtksourceview-2.11.2:3.0[introspection?]
- dev-libs/libpeas
- spell? (
- >=app-text/enchant-1.2
- >=app-text/iso-codes-0.35
- )"
-
-DEPEND="${RDEPEND}
- >=sys-devel/gettext-0.17
- >=dev-util/intltool-0.40
- >=dev-util/pkgconfig-0.9
- >=app-text/scrollkeeper-0.3.11
- >=app-text/gnome-doc-utils-0.3.2
- ~app-text/docbook-xml-dtd-4.1.2
- doc? ( >=dev-util/gtk-doc-1 )"
-
-DOCS="AUTHORS BUGS ChangeLog MAINTAINERS NEWS README"
-
-pkg_setup() {
- G2CONF="${G2CONF}
- --disable-scrollkeeper
- --disable-updater
- $(use_enable spell)"
-}
-
-src_prepare() {
- sed -i -e 's:--warn-all::g' gedit/Makefile.in || die
- gnome2_src_prepare
-}
-
-src_install() {
- gnome2_src_install
- find "${D}" -name "*.la" -delete || die "remove of la files failed"
-}