summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2010-03-06 13:54:42 +0100
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2010-03-06 13:54:42 +0100
commit40f3ac8550418f0cbac32a89992dff37a067f45e (patch)
treec192c7a6044b459428a0839e0dcf6e60f0d99757 /x11-terms
parentunmask keyring with a patch (diff)
downloadkeruspe-40f3ac8550418f0cbac32a89992dff37a067f45e.tar.gz
keruspe-40f3ac8550418f0cbac32a89992dff37a067f45e.tar.bz2
keruspe-40f3ac8550418f0cbac32a89992dff37a067f45e.zip
bump gnome-terminal
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/Manifest3
-rw-r--r--x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch11
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-2.29.6.ebuild34
3 files changed, 48 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
new file mode 100644
index 00000000..36bc9e96
--- /dev/null
+++ b/x11-terms/gnome-terminal/Manifest
@@ -0,0 +1,3 @@
+AUX gnome-terminal-2.22.0-default_shell.patch 491 RMD160 211ce1834251f5e4c80ba7511a2cacf8c4c43424 SHA1 47b5cad036c28fc0e750684c42582b9c13609d26 SHA256 efcd9d5074cb4653a3725008290d6b6ae5e8835cfbcbc25f3dfcaf3e7aad2892
+EBUILD gnome-terminal-2.29.6.ebuild 724 RMD160 5241548f84557bcb2266116d05b8648632819184 SHA1 abac91271a2a733cf2aba981aa9dbde8f96772ee SHA256 77429242178c2c242a4da30f96f099bd94b4bded0b2e7c64062a500a66d77dad
+DIST gnome-terminal-2.29.6.tar.bz2 2195584 RMD160 0d55ad92e3f2e82c52a7540bc9a584fcdd29aada SHA1 af33b86384018c87dc8ed27697b8501363188f67 SHA256 3a1083a67b6ddbec33aa36991c2e47ef6301ec343f24fa43247b028b0d00d669
diff --git a/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch b/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch
new file mode 100644
index 00000000..84bac04f
--- /dev/null
+++ b/x11-terms/gnome-terminal/files/gnome-terminal-2.22.0-default_shell.patch
@@ -0,0 +1,11 @@
+--- src/gnome-terminal.schemas.in 2003-02-21 20:06:56.000000000 -0600
++++ src/gnome-terminal.schemas.in 2003-02-21 20:07:13.000000000 -0600
+@@ -341,7 +341,7 @@
+ <applyto>/apps/gnome-terminal/profiles/Default/login_shell</applyto>
+ <owner>gnome-terminal</owner>
+ <type>bool</type>
+- <default>false</default>
++ <default>true</default>
+ <locale name="C">
+ <short>Whether to launch the command in the terminal as a login shell</short>
+ <long>
diff --git a/x11-terms/gnome-terminal/gnome-terminal-2.29.6.ebuild b/x11-terms/gnome-terminal/gnome-terminal-2.29.6.ebuild
new file mode 100644
index 00000000..9720aa5e
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-2.29.6.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=3
+inherit eutils gnome2
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.16.0
+ >=x11-libs/gtk+-2.14.0
+ >=gnome-base/gconf-2.14
+ >=x11-libs/startup-notification-0.8
+ >=x11-libs/vte-0.22.0
+ >=dev-libs/dbus-glib-0.6
+ x11-libs/libSM"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/intltool-0.40
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.3.2"
+
+DOCS="AUTHORS ChangeLog HACKING NEWS README"
+
+src_prepare() {
+ gnome2_src_prepare
+ epatch "${FILESDIR}"/${PN}-2.22.0-default_shell.patch
+}