summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-08-19 16:54:53 +0200
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-08-19 16:54:53 +0200
commitb008dcfaf36ac7e8780e84eaa35e133a281fe506 (patch)
tree3faf820bf4456fec9eb793f97ec4d625179abe09 /x11-libs
parentadd seahorse-plugins scm (diff)
downloadkeruspe-b008dcfaf36ac7e8780e84eaa35e133a281fe506.tar.gz
keruspe-b008dcfaf36ac7e8780e84eaa35e133a281fe506.tar.bz2
keruspe-b008dcfaf36ac7e8780e84eaa35e133a281fe506.zip
add libcryptui scm
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
Diffstat (limited to 'x11-libs')
-rw-r--r--x11-libs/libcryptui/Manifest1
-rw-r--r--x11-libs/libcryptui/libcryptui-9999-r1.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-libs/libcryptui/Manifest b/x11-libs/libcryptui/Manifest
new file mode 100644
index 00000000..8999004c
--- /dev/null
+++ b/x11-libs/libcryptui/Manifest
@@ -0,0 +1 @@
+EBUILD libcryptui-9999-r1.ebuild 1581 RMD160 480433f3c63d7be9acb3c54545661b7031499aa7 SHA1 a980c6209ca957ee2f6fe7c2c85f630bda3da249 SHA256 b3184418c6dd6e123da76a334c78ebb7ffc9ac22259be45cefc3ff2b7c78b18c
diff --git a/x11-libs/libcryptui/libcryptui-9999-r1.ebuild b/x11-libs/libcryptui/libcryptui-9999-r1.ebuild
new file mode 100644
index 00000000..fd538b93
--- /dev/null
+++ b/x11-libs/libcryptui/libcryptui-9999-r1.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2-live
+
+DESCRIPTION="User interface components for OpenPGP"
+HOMEPAGE="http://www.gnome.org/projects/seahorse/index.html"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+IUSE="debug doc +introspection libnotify test"
+KEYWORDS=""
+
+# Pull in libnotify-0.7 because it's controlled via an automagic ifdef
+COMMON_DEPEND="
+ >=gnome-base/gconf-2:2
+ >=dev-libs/glib-2.10:2
+ >=x11-libs/gtk+-2.90.0:3[introspection?]
+ >=dev-libs/dbus-glib-0.72
+ >=gnome-base/gnome-keyring-2.91.2
+
+ >=app-crypt/gpgme-1
+ || (
+ =app-crypt/gnupg-2.0*
+ =app-crypt/gnupg-1.4* )
+
+ introspection? ( >=dev-libs/gobject-introspection-0.6.4 )
+ libnotify? ( >=x11-libs/libnotify-0.7.0 )
+"
+DEPEND="${COMMON_DEPEND}
+ sys-devel/gettext
+ >=app-text/gnome-doc-utils-0.3.2
+ >=app-text/scrollkeeper-0.3
+ >=dev-util/pkgconfig-0.20
+ >=dev-util/intltool-0.35
+ doc? ( >=dev-util/gtk-doc-1.9 )
+"
+# Before 3.1.4, libcryptui was part of seahorse
+RDEPEND="${COMMON_DEPEND}
+ !!<app-crypt/seahorse-3.1.4
+"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-scrollkeeper
+ --disable-update-mime-database
+ $(use_enable debug)
+ $(use_enable introspection)
+ $(use_enable libnotify)
+ $(use_enable test tests)"
+ DOCS="AUTHORS ChangeLog NEWS README"
+}
+
+src_prepare() {
+ # FIXME: Do not mess with CFLAGS with USE="debug"
+ sed -e '/CFLAGS="$CFLAGS -g -O0/d' \
+ -e 's/-Werror//' \
+ -i configure.ac || die "sed failed"
+
+ gnome2_src_prepare
+}