summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-16 23:35:35 +0100
committerMarc-Antoine Perennou <Marc-Antoine@Perennou.com>2011-11-16 23:35:35 +0100
commit96e34c24f3ca206b917313d32540686f835c5922 (patch)
tree67f0a87d2b531aeadbeb8c93e2e989627ee22f02
parentgnome-shell: update deps (diff)
downloadkeruspe-96e34c24f3ca206b917313d32540686f835c5922.tar.gz
keruspe-96e34c24f3ca206b917313d32540686f835c5922.tar.bz2
keruspe-96e34c24f3ca206b917313d32540686f835c5922.zip
libpeas: port to vala 0.14
Signed-off-by: Marc-Antoine Perennou <Marc-Antoine@Perennou.com>
-rw-r--r--dev-libs/libpeas/Manifest1
-rw-r--r--dev-libs/libpeas/libpeas-9999-r1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-libs/libpeas/Manifest b/dev-libs/libpeas/Manifest
new file mode 100644
index 00000000..dadb6052
--- /dev/null
+++ b/dev-libs/libpeas/Manifest
@@ -0,0 +1 @@
+EBUILD libpeas-9999-r1.ebuild 1589 RMD160 0dc9a03f595060c66e21485895a5eac7058c7918 SHA1 56b64c2e33e01fad28113872629a50db86136ee5 SHA256 671a3202bfd0667615fd36bd17b64e51127ea9c4b704742a148d734231609520
diff --git a/dev-libs/libpeas/libpeas-9999-r1.ebuild b/dev-libs/libpeas/libpeas-9999-r1.ebuild
new file mode 100644
index 00000000..b0f9f6ca
--- /dev/null
+++ b/dev-libs/libpeas/libpeas-9999-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="python? 2:2.5"
+
+inherit gnome2-live python virtualx
+
+DESCRIPTION="A GObject plugins library"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="doc gjs +gtk glade +python seed vala"
+KEYWORDS=""
+
+RDEPEND=">=dev-libs/glib-2.23.6:2
+ >=dev-libs/gobject-introspection-0.10.1
+ gjs? ( >=dev-libs/gjs-1.29.16 )
+ glade? ( >=dev-util/glade-3.9.1:3.10 )
+ gtk? ( >=x11-libs/gtk+-2.91.1:3[introspection] )
+ python? ( >=dev-python/pygobject-3.0.0:3 )
+ seed? ( >=dev-libs/seed-2.91.91 )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.40
+ >=sys-devel/gettext-0.17
+ doc? ( >=dev-util/gtk-doc-1.11 )
+ vala? ( dev-lang/vala:0.14 )"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF}
+ $(use_enable gjs)
+ $(use_enable glade glade-catalog)
+ $(use_enable gtk)
+ $(use_enable python)
+ $(use_enable seed)
+ $(use_enable vala)
+ VALAC=$(type -P valac-0.14)
+ --disable-deprecation
+ --disable-static"
+ # Wtf, --disable-gcov, --enable-gcov=no, --enable-gcov, all enable gcov
+ # What do we do about gdb, valgrind, gcov, etc?
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_test() {
+ # FIXME: Tests fail because of some bug involving Xvfb and Gtk.IconTheme
+ # DO NOT REPORT UPSTREAM, this is not a libpeas bug.
+ # To reproduce:
+ # >>> from gi.repository import Gtk
+ # >>> Gtk.IconTheme.get_default().has_icon("gtk-about")
+ # This should return True, it returns False for Xvfb
+ Xemake check
+}