summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Riley <justin.t.riley@gmail.com>2012-05-24 16:04:22 -0400
committerJustin Riley <justin.t.riley@gmail.com>2012-05-24 16:04:22 -0400
commit445edfba0b938edf89e962a9227f03de8e3a8078 (patch)
tree996ca3d3f648fd326ab6a96081c2eeece8a75dcd /dev-python
parentemul-linux-x86-soundlibs: fix missing pulseaudio libs (diff)
downloadjtriley-445edfba0b938edf89e962a9227f03de8e3a8078.tar.gz
jtriley-445edfba0b938edf89e962a9227f03de8e3a8078.tar.bz2
jtriley-445edfba0b938edf89e962a9227f03de8e3a8078.zip
fix distutils deprecation warnings
* Deprecation Warning: Usage of distutils.eclass in packages not supporting installation for multiple Python ABIs in EAPI <=2 is deprecated and will be banned on 2011-06-01. The ebuild needs to be fixed. Please report a bug, if it has not been already reported.
Diffstat (limited to 'dev-python')
-rw-r--r--dev-python/java2python/java2python-0.2.ebuild6
-rw-r--r--dev-python/line_profiler/line_profiler-1.0_beta3.ebuild5
-rw-r--r--dev-python/parsedatetime/parsedatetime-0.8.7.ebuild5
-rw-r--r--dev-python/pymbolic/pymbolic-0.91.ebuild5
-rw-r--r--dev-python/synoptic/synoptic-0.91.5.ebuild5
5 files changed, 24 insertions, 2 deletions
diff --git a/dev-python/java2python/java2python-0.2.ebuild b/dev-python/java2python/java2python-0.2.ebuild
index eac4d6f..7daa8a9 100644
--- a/dev-python/java2python/java2python-0.2.ebuild
+++ b/dev-python/java2python/java2python-0.2.ebuild
@@ -2,12 +2,15 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+EAPI="4"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="java2python"
inherit distutils
-
DESCRIPTION="java2python: Imperfect Translation of Java Source Code to Python"
HOMEPAGE="http://code.google.com/p/java2python/"
SRC_URI="http://java2python.googlecode.com/files/${P}.tar.gz"
@@ -15,4 +18,3 @@ LICENSE="GPL-2"
KEYWORDS="~amd64"
SLOT="0"
IUSE=""
-
diff --git a/dev-python/line_profiler/line_profiler-1.0_beta3.ebuild b/dev-python/line_profiler/line_profiler-1.0_beta3.ebuild
index 4ee010c..b22a327 100644
--- a/dev-python/line_profiler/line_profiler-1.0_beta3.ebuild
+++ b/dev-python/line_profiler/line_profiler-1.0_beta3.ebuild
@@ -2,6 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
inherit distutils
diff --git a/dev-python/parsedatetime/parsedatetime-0.8.7.ebuild b/dev-python/parsedatetime/parsedatetime-0.8.7.ebuild
index 5e75a4e..98ded81 100644
--- a/dev-python/parsedatetime/parsedatetime-0.8.7.ebuild
+++ b/dev-python/parsedatetime/parsedatetime-0.8.7.ebuild
@@ -2,6 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="parsedatetime"
diff --git a/dev-python/pymbolic/pymbolic-0.91.ebuild b/dev-python/pymbolic/pymbolic-0.91.ebuild
index 00d71dc..f11a934 100644
--- a/dev-python/pymbolic/pymbolic-0.91.ebuild
+++ b/dev-python/pymbolic/pymbolic-0.91.ebuild
@@ -2,6 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="pymbolic"
diff --git a/dev-python/synoptic/synoptic-0.91.5.ebuild b/dev-python/synoptic/synoptic-0.91.5.ebuild
index 8a6d465..d565a01 100644
--- a/dev-python/synoptic/synoptic-0.91.5.ebuild
+++ b/dev-python/synoptic/synoptic-0.91.5.ebuild
@@ -2,6 +2,11 @@
# Distributed under the terms of the GNU General Public License v2
# $Header: $
# Ebuild generated by g-pypi 0.2.2 (rev. 214)
+EAPI="4"
+
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="synoptic"