summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/apktool/apktool-2.8.1.ebuild')
-rw-r--r--dev-util/apktool/apktool-2.8.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/apktool/apktool-2.8.1.ebuild b/dev-util/apktool/apktool-2.8.1.ebuild
new file mode 100644
index 0000000..17e6e5e
--- /dev/null
+++ b/dev-util/apktool/apktool-2.8.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A tool for reengineering 3rd party, closed, binary Android apps"
+HOMEPAGE="https://ibotpeaches.github.io/Apktool/"
+SRC_URI="https://github.com/iBotPeaches/Apktool/releases/download/v${PV}/apktool_${PV}.jar"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="tools"
+
+DEPEND=""
+RDEPEND="|| ( virtual/jre virtual/jdk )
+ tools? ( dev-util/android-sdk-build-tools )"
+
+S="${WORKDIR}"
+
+src_unpack() {
+ dodir "${S}"
+ cp -L "${DISTDIR}/${A}" "${S}/${PN}.jar" || die
+}
+
+src_install() {
+ dobin "${FILESDIR}/apktool"
+ insinto "/opt/${PN}/"
+ doins apktool.jar
+}