aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild')
-rw-r--r--media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild67
1 files changed, 0 insertions, 67 deletions
diff --git a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild b/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild
deleted file mode 100644
index 8d3c1f3..0000000
--- a/media-plugins/libvisual-plugins/libvisual-plugins-0.4.0-r3.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: $
-
-EAPI=4
-inherit autotools eutils multilib-minimal
-
-PATCHLEVEL=4
-
-DESCRIPTION="collection of visualization plugins for use with the libvisual framework"
-HOMEPAGE="http://libvisual.sourceforge.net/"
-SRC_URI="mirror://sourceforge/libvisual/${P}.tar.gz
- mirror://gentoo/${P}-patches-${PATCHLEVEL}.tar.bz2
- mirror://gentoo/${P}-m4-1.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0.4"
-KEYWORDS="~amd64"
-IUSE="alsa debug gtk jack mplayer opengl"
-
-RDEPEND="media-libs/fontconfig[${MULTILIB_USEDEP}]
- ~media-libs/libvisual-${PV}[${MULTILIB_USEDEP}]
- x11-libs/libX11[${MULTILIB_USEDEP}]
- x11-libs/libXext[${MULTILIB_USEDEP}]
- x11-libs/libXrender[${MULTILIB_USEDEP}]
- alsa? ( media-libs/alsa-lib[${MULTILIB_USEDEP}] )
- gtk? ( x11-libs/gtk+:2[${MULTILIB_USEDEP}] )
- jack? ( >=media-sound/jack-audio-connection-kit-0.109[${MULTILIB_USEDEP}] )
- opengl? (
- virtual/glu[${MULTILIB_USEDEP}]
- virtual/opengl[${MULTILIB_USEDEP}]
- )"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- x11-libs/libXt[${MULTILIB_USEDEP}]"
-
-DOCS="AUTHORS ChangeLog NEWS README TODO"
-
-MULTILIB_PARALLEL_PHASES="src_compile src_install"
-
-src_prepare() {
- EPATCH_SUFFIX=patch epatch "${WORKDIR}"/patches
- AT_M4DIR=${WORKDIR}/m4 eautoreconf
-
- sed -i -e "s:@MKINSTALLDIRS@:${S}/mkinstalldirs:" po/Makefile.* || die
-}
-
-multilib_src_configure() {
- ECONF_SOURCE="${S}" econf \
- --disable-esd \
- $(use_enable jack) \
- $(use_enable gtk gdkpixbuf-plugin) \
- --disable-gstreamer-plugin \
- $(use_enable alsa) \
- $(use_enable mplayer) \
- $(use_enable debug inputdebug) \
- $(use_enable opengl gltest) \
- $(use_enable opengl nastyfft) \
- $(use_enable opengl madspin) \
- $(use_enable opengl flower) \
- $(use_enable debug)
-}
-
-multilib_src_install_all() {
- find "${ED}"/usr -type f -name '*.la' -exec rm -f {} +
- dodoc ${DOCS}
-}