aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/graphite2/graphite2-1.2.1-r1.ebuild')
-rw-r--r--media-gfx/graphite2/graphite2-1.2.1-r1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/media-gfx/graphite2/graphite2-1.2.1-r1.ebuild b/media-gfx/graphite2/graphite2-1.2.1-r1.ebuild
index 982330a..5d3c3b8 100644
--- a/media-gfx/graphite2/graphite2-1.2.1-r1.ebuild
+++ b/media-gfx/graphite2/graphite2-1.2.1-r1.ebuild
@@ -7,7 +7,7 @@ EAPI=5
PYTHON_COMPAT=( python{2_6,2_7} )
GENTOO_DEPEND_ON_PERL="no"
-inherit base eutils cmake-utils perl-module python-any-r1
+inherit base eutils cmake-multilib perl-module python-any-r1
DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
HOMEPAGE="http://graphite.sil.org/"
@@ -24,9 +24,9 @@ RDEPEND="
DEPEND="${RDEPEND}
perl? ( virtual/perl-Module-Build )
test? (
- dev-libs/glib:2
- media-libs/fontconfig
- media-libs/silgraphite
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ media-libs/fontconfig[${MULTILIB_USEDEP}]
+ media-libs/silgraphite[${MULTILIB_USEDEP}]
${PYTHON_DEPS}
)
"
@@ -44,7 +44,7 @@ pkg_setup() {
}
src_prepare() {
- base_src_prepare
+ cmake-multilib_src_prepare
# fix perl linking
if use perl; then
@@ -70,11 +70,11 @@ src_configure() {
echo "-DGRAPHITE2_NSEGCACHE:BOOL=ON")
)
- cmake-utils_src_configure
+ cmake-multilib_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake-multilib_src_compile
if use perl; then
cd contrib/perl
perl-module_src_prep
@@ -83,7 +83,7 @@ src_compile() {
}
src_test() {
- cmake-utils_src_test
+ cmake-multilib_src_test
if use perl; then
cd contrib/perl
perl-module_src_test
@@ -91,7 +91,7 @@ src_test() {
}
src_install() {
- cmake-utils_src_install
+ cmake-multilib_src_install
if use perl; then
cd contrib/perl
perl-module_src_install