summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authoreroen <eroen@occam.eroen.eu>2014-09-09 20:27:13 +0200
committereroen <eroen@occam.eroen.eu>2014-09-09 20:27:13 +0200
commit4822c7c73032915607b75bfd725eb0bdbdc1fcad (patch)
tree31fd1b6ae68e0ecf1d55c606e7e20dd3b8e803e2
parentwine - eselect something in pkg_postrm too (diff)
downloaderoen-4822c7c73032915607b75bfd725eb0bdbdc1fcad.tar.gz
eroen-4822c7c73032915607b75bfd725eb0bdbdc1fcad.tar.bz2
eroen-4822c7c73032915607b75bfd725eb0bdbdc1fcad.zip
wine-gentoo - new ebuild
-rw-r--r--app-emulation/wine-gentoo/Manifest1
-rw-r--r--app-emulation/wine-gentoo/metadata.xml4
-rw-r--r--app-emulation/wine-gentoo/wine-gentoo-2013.06.24.ebuild27
3 files changed, 32 insertions, 0 deletions
diff --git a/app-emulation/wine-gentoo/Manifest b/app-emulation/wine-gentoo/Manifest
new file mode 100644
index 0000000..8af0bf2
--- /dev/null
+++ b/app-emulation/wine-gentoo/Manifest
@@ -0,0 +1 @@
+DIST wine-gentoo-2013.06.24.tar.bz2 85442 SHA256 bfbf6b25e98f717320de2ede467e3628fbc749d936b8449f8477c9dc6f41e04b SHA512 b6819889314f6a6ea16c1332f4b177c43623116763969c31b23b61754cd304dd085f5d3eafbe847159331eb97dddd9b4c10699430129ea4a71da418c1fe175f0 WHIRLPOOL 227e0ac6569736d4ad5813cef49f775dae956f4fc9255de95753d5d3cba1bf6cf3db31d23d3702bb54d2e60c5a6f779b602f0efb2096e4c827c924565b273d00
diff --git a/app-emulation/wine-gentoo/metadata.xml b/app-emulation/wine-gentoo/metadata.xml
new file mode 100644
index 0000000..097975e
--- /dev/null
+++ b/app-emulation/wine-gentoo/metadata.xml
@@ -0,0 +1,4 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+</pkgmetadata>
diff --git a/app-emulation/wine-gentoo/wine-gentoo-2013.06.24.ebuild b/app-emulation/wine-gentoo/wine-gentoo-2013.06.24.ebuild
new file mode 100644
index 0000000..3eba132
--- /dev/null
+++ b/app-emulation/wine-gentoo/wine-gentoo-2013.06.24.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+DESCRIPTION="Menu items and icons for wine"
+HOMEPAGE="http://dev.gentoo.org/~tetromino/distfiles/wine"
+SRC_URI="http://dev.gentoo.org/~tetromino/distfiles/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64" # ~x86 ~x86-fbsd
+IUSE=""
+
+RDEPEND="!app-emulation/wine[-multislot(-)]"
+
+# These use a non-standard "Wine" category, which is provided by
+# /etc/xdg/applications-merged/wine.menu
+QA_DESKTOP_FILE="usr/share/applications/wine-browsedrive.desktop
+usr/share/applications/wine-notepad.desktop
+usr/share/applications/wine-uninstaller.desktop
+usr/share/applications/wine-winecfg.desktop"
+
+src_install() {
+ emake install DESTDIR="${D}" EPREFIX="${EPREFIX}"
+}