summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorroot <root@ohmu.sfnt.local>2008-12-09 14:50:17 -0500
committerroot <root@ohmu.sfnt.local>2008-12-09 14:50:17 -0500
commit95db0492abb926f7de642564260cf54454c76ad4 (patch)
tree13cc9b962d961f52289a5fc6b29a5a02c9cc1fcb
parentFixed the problem with consolekit. (diff)
downloadeatnumber1-95db0492abb926f7de642564260cf54454c76ad4.tar.gz
eatnumber1-95db0492abb926f7de642564260cf54454c76ad4.tar.bz2
eatnumber1-95db0492abb926f7de642564260cf54454c76ad4.zip
Add modified mount-cifs with suid support.
-rw-r--r--net-fs/mount-cifs/Manifest3
-rw-r--r--net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff23
-rw-r--r--net-fs/mount-cifs/mount-cifs-3.0.28.ebuild40
3 files changed, 66 insertions, 0 deletions
diff --git a/net-fs/mount-cifs/Manifest b/net-fs/mount-cifs/Manifest
new file mode 100644
index 0000000..f9b1b23
--- /dev/null
+++ b/net-fs/mount-cifs/Manifest
@@ -0,0 +1,3 @@
+AUX user-unmount-ioctl-fix-bug4784.diff 902 RMD160 81db4c519599e8a52e94785456648bfd4bce9d26 SHA1 8976cd5beada8641afd8b3c1c5d0dbd193c940f3 SHA256 a3c7be6dddf81bf0b0523d7a21aec54d5dd4cf5f4ab43598823808340d823a2a
+DIST mount-cifs-3.0.28.tar.bz2 21764 RMD160 03607cf63aaeef074e03d2e3758f7a1dd19d47e3 SHA1 a622b2e797deebeec1fb695f1a7e03ee6bed398b SHA256 fd0164979182010a034b93e4ad7974a03bf4c431470a1c93ac99fd4b5bd8b2af
+EBUILD mount-cifs-3.0.28.ebuild 1208 RMD160 4b8944f25a0877144ad839fab95e54dddfbb3c02 SHA1 7bd8dd44adf9a36b385ab72d3e9db43f5e4f2de5 SHA256 85d1166b557121ea412b4546f1e8d7a44ef2252627be6d32b07abc3383cc40b5
diff --git a/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff b/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff
new file mode 100644
index 0000000..7be08ff
--- /dev/null
+++ b/net-fs/mount-cifs/files/user-unmount-ioctl-fix-bug4784.diff
@@ -0,0 +1,23 @@
+From: Jeremy Allison <jra@samba.org>
+Date: Thu, 13 Dec 2007 02:45:20 +0000 (-0800)
+Subject: Fix bug #4784. Patch from Steve Langasek <vorlon@debian.org>.
+X-Git-Url: http://gitweb.samba.org/?p=samba.git;a=commitdiff_plain;h=244230eb619c6699e962bb24f8f6e4dd2a1235c7
+
+Fix bug #4784. Patch from Steve Langasek <vorlon@debian.org>.
+Jeremy.
+---
+
+diff --git a/source/client/umount.cifs.c b/source/client/umount.cifs.c
+index 47ddd1e..70829eb 100644
+--- a/source/client/umount.cifs.c
++++ b/source/client/umount.cifs.c
+@@ -131,7 +131,7 @@ static int umount_check_perm(char * dir)
+ printf("user unmounting via %s is an optional feature of",thisprogram);
+ printf(" the cifs filesystem driver (cifs.ko)");
+ printf("\n\tand requires cifs.ko version 1.32 or later\n");
+- } else if (rc > 0)
++ } else if (rc != 0)
+ printf("user unmount of %s failed with %d %s\n",dir,errno,strerror(errno));
+ close(fileid);
+
+
diff --git a/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild b/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild
new file mode 100644
index 0000000..46d7acf
--- /dev/null
+++ b/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/mount-cifs/mount-cifs-3.0.28.ebuild,v 1.6 2008/02/01 14:07:27 armin76 Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="cifs filesystem mount helper split from Samba"
+HOMEPAGE="http://linux-cifs.samba.org/cifs/cifs_download.html"
+SRC_URI="http://dev.gentooexperimental.org/~jakub/distfiles/${P}.tar.bz2
+ mirror://gentoo/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 ~s390 ~sh sparc x86"
+IUSE="suid"
+
+DEPEND="!<net-fs/samba-3.0.25"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/user-unmount-ioctl-fix-bug4784.diff
+}
+
+src_compile() {
+ cd "${S}/source/client"
+ $(tc-getCC) ${CFLAGS} mount.cifs.c -o mount.cifs || die "make mount.cifs failed"
+ $(tc-getCC) ${CFLAGS} umount.cifs.c -o umount.cifs || die "make umount.cifs failed"
+}
+
+src_install() {
+ dobin source/client/{mount,umount}.cifs
+ dosym /usr/bin/mount.cifs /sbin/mount.cifs
+
+ docinto html
+ dohtml docs/htmldocs/*
+ doman docs/manpages/{mount,umount}.cifs.8
+
+ use suid && chmod u+s "${D}/${PREFIX}"/usr/bin/{mount,umount}.cifs
+}