summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-07-03 21:57:36 -0400
committerElijah El Lazkani <ThyArmageddon+GentooOverlay@Gmail.com>2013-07-03 21:57:36 -0400
commite245e4dab55f06a80dd31b9ea07b74834570e059 (patch)
treeecb7bcc04bde3765f217225d16fc5f69d195387e /games-rpg
parentFixed echo typo, thanks to rypervenche... (diff)
downloadArmageddon-e245e4dab55f06a80dd31b9ea07b74834570e059.tar.gz
Armageddon-e245e4dab55f06a80dd31b9ea07b74834570e059.tar.bz2
Armageddon-e245e4dab55f06a80dd31b9ea07b74834570e059.zip
Add Solarus engine, zsdx and some cleaning.
Diffstat (limited to 'games-rpg')
-rw-r--r--games-rpg/zsdx/Manifest1
-rw-r--r--games-rpg/zsdx/metadata.xml9
-rw-r--r--games-rpg/zsdx/zsdx-1.6.2.ebuild32
3 files changed, 42 insertions, 0 deletions
diff --git a/games-rpg/zsdx/Manifest b/games-rpg/zsdx/Manifest
new file mode 100644
index 0000000..0acc49a
--- /dev/null
+++ b/games-rpg/zsdx/Manifest
@@ -0,0 +1 @@
+DIST zsdx-1.6.2.tar.gz 11744669 SHA256 4a15839d3db98bc7c770eac5983e283223cb29a69f648f015d21c71ce32d850a SHA512 6cad6909c348824456f49a5e24761c8924fb385bc3de479422710ad2edc7e4c229591d8cbf51abe181480c14517abe992381da2b3701374a1d33ae19657e9991 WHIRLPOOL 055bd0267abd79f7219e6d9b73e49f161fefe74b9f54ca11681f2d8ee9c88b36cad49b1d92682207cf8ec25668fdf574227738cb69fb6fe2745aaec045a7423c
diff --git a/games-rpg/zsdx/metadata.xml b/games-rpg/zsdx/metadata.xml
new file mode 100644
index 0000000..45dbce1
--- /dev/null
+++ b/games-rpg/zsdx/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>ThyArmageddon+Gentoo@Gmail.com</email>
+ <name>Elijah El Lazkani</name>
+ </maintainer>
+ <longdescription lang="en">The Legend of Zelda: Mystery of Solarus DX is set to be a direct sequel to The Legend of Zelda: A Link to the Past on the SNES, using the same graphics and game mechanisms. Zelda Mystery of Solarus DX is the first game made with the Solarus engine and in fact, Solarus was primarily designed for this game.</longdescription>
+</pkgmetadata>
diff --git a/games-rpg/zsdx/zsdx-1.6.2.ebuild b/games-rpg/zsdx/zsdx-1.6.2.ebuild
new file mode 100644
index 0000000..7ef37bd
--- /dev/null
+++ b/games-rpg/zsdx/zsdx-1.6.2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: $
+
+EAPI=5
+
+inherit games cmake-utils
+
+DESCRIPTION="A free 2D Zelda fangame"
+HOMEPAGE="http://www.solarus-games.org/"
+SRC_URI="http://www.zelda-solarus.com/downloads/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+
+RDEPEND="=games-engines/solarus-1.0.4"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+ make_desktop_entry ${PN} "Zelda: Mystery of Solarus DX"
+}