summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPhilip Miess <Philip_Miess@yahoo.com>2017-10-25 22:00:22 -0400
committerPhilip Miess <Philip_Miess@yahoo.com>2017-10-25 22:00:22 -0400
commita084f58e7082908822a0ded00cee59384bc6d1fd (patch)
tree73e489b3da66d5b164b593d1f6bd42b5a854c3e6 /app-text
parentswig v1 (diff)
downloadsuperposition-a084f58e7082908822a0ded00cee59384bc6d1fd.tar.gz
superposition-a084f58e7082908822a0ded00cee59384bc6d1fd.tar.bz2
superposition-a084f58e7082908822a0ded00cee59384bc6d1fd.zip
require python, binding built when disabled
Diffstat (limited to 'app-text')
-rw-r--r--app-text/presage/Manifest2
-rw-r--r--app-text/presage/presage-0.8.9.ebuild16
2 files changed, 10 insertions, 8 deletions
diff --git a/app-text/presage/Manifest b/app-text/presage/Manifest
index 5a1b674..df1c5d9 100644
--- a/app-text/presage/Manifest
+++ b/app-text/presage/Manifest
@@ -1,3 +1,3 @@
AUX presage-0.8.9-automagic.patch 4425 SHA256 21e95d42cc08aaf89a686989f0e7d55c22868fd7603c8c76cd31bf1fbc9ed354 SHA512 e57ec49b442f8eb08c9a0a62572acab60b5aa0bfe88a0f8552a7959cbf38fa296d00a83c96e82e727bd21fc5ab07a4b3296b51b7929fea4ca69e4922ddfd3e3a WHIRLPOOL e568e83ecc6d24f7d9ce9b4aa93a45e3316501afba8e946ede2f3b012abae3fe1f935ac1ff09b293ced5858dec1b876c560e20803869b75eb59e9ff54aa165dc
DIST presage-0.8.9.tar.gz 2568505 SHA256 5541e9b350cc603a8d412704dcfa21342369b5b07c6da91947c7523c51678cd0 SHA512 62206497283b3d7d29546399ea94c5b82d95c91f09c14e48098e1a8791018ccfdda26c46227195cdf706c0097e02bf382360e0a9c7e824edcd86fdfa5f4c3db1 WHIRLPOOL 029d3366c94fc52ba0a8337197158cc53d6aba8c276d2ddd52f5f58b864a7da2388af5d67342ece1817a7863fea2f6b675e76bb1e3555df4a1ddd67296a65188
-EBUILD presage-0.8.9.ebuild 1252 SHA256 cc44b5316136bf13c6e25f065e6b51085bcbd5c8987fb76801c18fa5dffcd673 SHA512 3c5ddd3eea1a9490d7e719971696b74c1324b476b00acf48f0ba906419124f3a5ae179bb8e43fb116e5a34f2bccd1cd9b7dba26402853bf3e9701be5e51cd53c WHIRLPOOL bb2cb6b2083d384a77c266f12ea4c258fc3100587ffc39b5b681af07bd53661dbcfbcf787c8d30d5b96c534527fbfc8c7e84ea89cc4a6261cdb5e39fb909de4b
+EBUILD presage-0.8.9.ebuild 1253 SHA256 b139ee84be8c4085d8c4f0dd8189458084ee7e1c15018544d5ecb58368b10973 SHA512 fad4e0f6b99063344a3b9292c2785720825918601f427f8f526c6ff7a912ae6a8fcd9efc071e6aee0d4cfedf5f3ee85800c61e41e4687c1cefc6616f1ae07e67 WHIRLPOOL 2aa4d2d6afe80ea1d31bab40eb3f566968322fa4fdee230c4ad915f28637784f33a4c8c871b2facfff978a978dac883acf8aadf65a1115499f29c1c50657be96
diff --git a/app-text/presage/presage-0.8.9.ebuild b/app-text/presage/presage-0.8.9.ebuild
index 55a3e04..affdd9d 100644
--- a/app-text/presage/presage-0.8.9.ebuild
+++ b/app-text/presage/presage-0.8.9.ebuild
@@ -14,20 +14,22 @@ SRC_URI="mirror://sourceforge/${PN}/${PV}/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc examples gtk python sqlite test"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+IUSE="doc examples gtk sqlite test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
RDEPEND="
examples? ( sys-libs/ncurses )
gtk? ( x11-libs/gtk+ )
- python? ( ${PYTHON_DEPS} dev-python/dbus-python[${PYTHON_USEDEP}] )
+ ${PYTHON_DEPS}
+ dev-python/dbus-python[${PYTHON_USEDEP}]
sqlite? ( dev-db/sqlite )
app-text/dos2unix
"
DEPEND="${COMMON_DEPEND}
doc? ( app-doc/doxygen )
- python? ( ${PYTHON_DEPS} dev-lang/swig:1 )
+ ${PYTHON_DEPS}
+ dev-lang/swig:1
test? ( dev-util/cppunit )
sys-apps/help2man
"
@@ -45,11 +47,11 @@ src_configure() {
$(use_enable doc documentation)
$(use_enable examples curses)
$(use_enable gtk gpresagemate)
- $(use_enable python)
- $(use_enable python python-binding)
+ #$(use_enable python)
+ #$(use_enable python python-binding)
$(use_enable sqlite)
$(use_enable test)
)
- econf ${myeconfargs} --disable-gprompter
+ econf ${myeconfargs} --enable-python --enable-python-binding --disable-gprompter
}