summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-17 16:42:35 -0700
committerJohn M. Harris, Jr. <johnmh@johnmh.me>2024-06-17 16:42:35 -0700
commitbd31a56ceb2ccaed25fe3e6bbb4fccb9c56eed77 (patch)
tree66a365a7b3edd5b159a751bb910d2180749777d4
parentdev-libs/hyprlang: Add ebuild (diff)
downloadjohnmh-bd31a56ceb2ccaed25fe3e6bbb4fccb9c56eed77.tar.gz
johnmh-bd31a56ceb2ccaed25fe3e6bbb4fccb9c56eed77.tar.bz2
johnmh-bd31a56ceb2ccaed25fe3e6bbb4fccb9c56eed77.zip
dev-util/hyprwayland-scanner: Add ebuild
Signed-off-by: John M. Harris, Jr. <johnmh@johnmh.me>
-rw-r--r--dev-util/hyprwayland-scanner/Manifest1
-rw-r--r--dev-util/hyprwayland-scanner/hyprwayland-scanner-9999.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-util/hyprwayland-scanner/Manifest b/dev-util/hyprwayland-scanner/Manifest
new file mode 100644
index 0000000..46d3c89
--- /dev/null
+++ b/dev-util/hyprwayland-scanner/Manifest
@@ -0,0 +1 @@
+EBUILD hyprwayland-scanner-9999.ebuild 1106 BLAKE2B 4b658bd56b853c4a5455a8e52e55a3acccf159ff4c84bfc81ca7f28baa664c5030d2d3f83ed532319a9b07f3a50e1b6045bd3aebe3a9874afe3a4562fd517c14 SHA512 26b3e95c514c667cb37bf098ea670d223d6bf7f91828638bb364a554d8453d706addbe2f706a1edc3d8e6512c77f804300f338a1beaee591eded7518d93569ee
diff --git a/dev-util/hyprwayland-scanner/hyprwayland-scanner-9999.ebuild b/dev-util/hyprwayland-scanner/hyprwayland-scanner-9999.ebuild
new file mode 100644
index 0000000..c48449c
--- /dev/null
+++ b/dev-util/hyprwayland-scanner/hyprwayland-scanner-9999.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs
+
+DESCRIPTION="A Hyprland implementation of wayland-scanner, in and for C++"
+HOMEPAGE="https://github.com/hyprwm/hyprwayland-scanner/"
+
+if [[ ${PV} == 9999 ]] ; then
+ EGIT_REPO_URI="https://github.com/hyprwm/hyprwayland-scanner.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/hyprwm/hyprwayland-scanner/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+
+RDEPEND=">=dev-libs/pugixml-1.14"
+DEPEND="${RDEPEND}"
+
+pkg_setup() {
+ [[ ${MERGE_TYPE} == binary ]] && return
+
+ if tc-is-gcc && ver_test $(gcc-version) -lt 13 ; then
+ eerror "Hyprland requires >=sys-devel/gcc-13 to build"
+ eerror "Please upgrade GCC: emerge -v1 sys-devel/gcc"
+ die "GCC version is too old to compile Hyprland!"
+ elif tc-is-clang && ver_test $(clang-version) -lt 16 ; then
+ eerror "Hyprland requires >=sys-devel/clang-16 to build"
+ eerror "Please upgrade Clang: emerge -v1 sys-devel/clang"
+ die "Clang version is too old to compile Hyprland!"
+ fi
+}