summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-plugins/asmem/asmem-1.12-r2.ebuild')
-rw-r--r--x11-plugins/asmem/asmem-1.12-r2.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/x11-plugins/asmem/asmem-1.12-r2.ebuild b/x11-plugins/asmem/asmem-1.12-r2.ebuild
new file mode 100644
index 000000000000..47c255eede9c
--- /dev/null
+++ b/x11-plugins/asmem/asmem-1.12-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Monitor the utilization level of memory, cache and swap space"
+HOMEPAGE="http://www.tigr.net/"
+SRC_URI="http://www.tigr.net/afterstep/download/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+IUSE="jpeg"
+
+RDEPEND="
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libXpm
+ x11-libs/libXext
+ jpeg? ( media-libs/libjpeg-turbo:= )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+PATCHES=(
+ "${FILESDIR}"/respect-ldflags.patch
+ "${FILESDIR}"/configure-implicit-func-decls.patch
+)
+
+src_configure() {
+ econf $(use_enable jpeg)
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ einstalldocs
+
+ dobin ${PN}
+ newman ${PN}.man ${PN}.1
+}