summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'x11-misc/xwit')
-rw-r--r--x11-misc/xwit/Manifest1
-rw-r--r--x11-misc/xwit/files/Makefile6
-rw-r--r--x11-misc/xwit/files/malloc.patch11
-rw-r--r--x11-misc/xwit/files/xwit-3.4-malloc-includes.patch49
-rw-r--r--x11-misc/xwit/metadata.xml5
-rw-r--r--x11-misc/xwit/xwit-3.4-r1.ebuild33
-rw-r--r--x11-misc/xwit/xwit-3.4.ebuild34
7 files changed, 139 insertions, 0 deletions
diff --git a/x11-misc/xwit/Manifest b/x11-misc/xwit/Manifest
new file mode 100644
index 000000000000..e1d32c6e0b94
--- /dev/null
+++ b/x11-misc/xwit/Manifest
@@ -0,0 +1 @@
+DIST xwit-3.4.tar.gz 14536 SHA256 d915a7f2f8809da41edcc7784c2618be3f8ce179d82d8ace6d27ba264332c729 SHA512 db0cc8cd7e899790493ca97fa4f12869385d1cfaa807298476d961401004d752531fe75ec72520733e78d81dcd91009c1b4437295056dc1de6219d766235cc5f WHIRLPOOL a72beed7ee71abc4b1679979bb05185f97fe905f2bf36b1bab6cc9874fc282b303ce458e5f1acdc9497fdc545444582f1e943d014c2747782bbbd0b70f961b08
diff --git a/x11-misc/xwit/files/Makefile b/x11-misc/xwit/files/Makefile
new file mode 100644
index 000000000000..7b106f0d7168
--- /dev/null
+++ b/x11-misc/xwit/files/Makefile
@@ -0,0 +1,6 @@
+src = xwit.c dsimple.c ClientWin.c
+
+all: xwit
+
+xwit: $(o)
+ $(CC) $(CPPFLAGS) $(CFLAGS) $(LDFLAGS) $(src) -o xwit -lX11
diff --git a/x11-misc/xwit/files/malloc.patch b/x11-misc/xwit/files/malloc.patch
new file mode 100644
index 000000000000..41c3a7b82eff
--- /dev/null
+++ b/x11-misc/xwit/files/malloc.patch
@@ -0,0 +1,11 @@
+--- dsimple.c_ 2005-06-05 16:07:10.000000000 +0200
++++ dsimple.c 2005-06-05 16:07:47.000000000 +0200
+@@ -46,7 +46,7 @@
+ char *Malloc(size)
+ unsigned size;
+ {
+- char *data, *malloc();
++ char *data; //, *malloc();
+
+ if (!(data = malloc(size)))
+ Fatal_Error("Out of memory!");
diff --git a/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch b/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch
new file mode 100644
index 000000000000..beda933c19f3
--- /dev/null
+++ b/x11-misc/xwit/files/xwit-3.4-malloc-includes.patch
@@ -0,0 +1,49 @@
+--- a/dsimple.c 1995-10-19 00:59:17.000000000 +0100
++++ b/dsimple.c 2013-08-03 18:27:16.670506562 +0200
+@@ -5,6 +5,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+ #include <stdio.h>
++#include <stdlib.h> /* malloc() */
++#include <unistd.h> /* exit() */
+ /*
+ * Other_stuff.h: Definitions of routines in other_stuff.
+ *
+@@ -46,7 +48,7 @@
+ char *Malloc(size)
+ unsigned size;
+ {
+- char *data, *malloc();
++ char *data; /*, *malloc(); */
+
+ if (!(data = malloc(size)))
+ Fatal_Error("Out of memory!");
+@@ -62,7 +64,7 @@
+ char *ptr;
+ int size;
+ {
+- char *new_ptr, *realloc();
++ char *new_ptr; /*, *realloc(); */
+
+ if (!ptr)
+ return(Malloc(size));
+--- a/xwit.c 1997-10-21 03:32:54.000000000 +0200
++++ b/xwit.c 2013-08-03 18:38:52.075456902 +0200
+@@ -31,6 +31,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/Xproto.h>
+ #include <stdio.h>
++#include <stdlib.h> /* atoi() */
++#include <sys/select.h> /* select() */
+ #include <sys/time.h>
+ #include "dsimple.h"
+
+@@ -134,7 +136,7 @@
+ struct timeval tv;
+ tv.tv_sec = ms/1000;
+ tv.tv_usec = (ms%1000)*1000;
+- select(0,(int*)0,(int*)0,(int*)0,&tv);
++ select(0,0,0,0,&tv);
+ }
+
+ /*
diff --git a/x11-misc/xwit/metadata.xml b/x11-misc/xwit/metadata.xml
new file mode 100644
index 000000000000..2518313f5241
--- /dev/null
+++ b/x11-misc/xwit/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>
diff --git a/x11-misc/xwit/xwit-3.4-r1.ebuild b/x11-misc/xwit/xwit-3.4-r1.ebuild
new file mode 100644
index 000000000000..758c1a806724
--- /dev/null
+++ b/x11-misc/xwit/xwit-3.4-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A collection of simple routines to call some of those X11 functions"
+HOMEPAGE="http://ftp.x.org/contrib/utilities/xwit-3.4.README"
+SRC_URI="http://ftp.x.org/contrib/utilities/${P}.tar.gz"
+
+LICENSE="public-domain HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-malloc-includes.patch
+
+ cp -vf "${FILESDIR}"/Makefile .
+
+ tc-export CC
+}
+
+src_install() {
+ dobin xwit
+ newman xwit.man xwit.1
+ dodoc README
+}
diff --git a/x11-misc/xwit/xwit-3.4.ebuild b/x11-misc/xwit/xwit-3.4.ebuild
new file mode 100644
index 000000000000..efacade6cb14
--- /dev/null
+++ b/x11-misc/xwit/xwit-3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A collection of simple routines to call some of those X11 functions"
+HOMEPAGE="http://ftp.x.org/contrib/utilities/xwit-3.4.README"
+SRC_URI="http://ftp.x.org/contrib/utilities/${P}.tar.gz"
+
+LICENSE="public-domain HPND"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/malloc.patch
+ cp -vf "${FILESDIR}"/Makefile .
+}
+
+src_compile() {
+ tc-export CC
+ emake || die
+}
+
+src_install() {
+ dobin xwit || die
+ newman xwit.man xwit.1 || die
+}