summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-libs/tevent/tevent-0.9.33.ebuild')
-rw-r--r--sys-libs/tevent/tevent-0.9.33.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/sys-libs/tevent/tevent-0.9.33.ebuild b/sys-libs/tevent/tevent-0.9.33.ebuild
index c454b5e965eb..fc46807e4d12 100644
--- a/sys-libs/tevent/tevent-0.9.33.ebuild
+++ b/sys-libs/tevent/tevent-0.9.33.ebuild
@@ -26,6 +26,10 @@ DEPEND="${RDEPEND}
# build system does not work with python3
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+PATCHES=(
+ "${FILESDIR}"/talloc-disable-python.patch
+)
+
WAF_BINARY="${S}/buildtools/bin/waf"
pkg_setup() {
@@ -39,6 +43,8 @@ src_prepare() {
multilib_src_configure() {
waf-utils_src_configure \
+ --bundled-libraries=NONE \
+ --builtin-libraries=NONE \
$(multilib_native_usex python '' '--disable-python')
}