summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-fs/erofs-utils/erofs-utils-1.6-r1.ebuild')
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.6-r1.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/sys-fs/erofs-utils/erofs-utils-1.6-r1.ebuild b/sys-fs/erofs-utils/erofs-utils-1.6-r1.ebuild
deleted file mode 100644
index 87fe99420cfd..000000000000
--- a/sys-fs/erofs-utils/erofs-utils-1.6-r1.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-inherit autotools
-
-DESCRIPTION="Userspace tools for EROFS"
-HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
-LICENSE="GPL-2+"
-
-SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/${PN}.git/snapshot/${P}.tar.gz"
-KEYWORDS="~amd64 ~loong"
-
-SLOT="0"
-IUSE="fuse +lz4 +lzma selinux +uuid"
-
-RDEPEND="
- fuse? ( sys-fs/fuse:0 )
- lz4? ( app-arch/lz4:0= )
- lzma? ( >=app-arch/xz-utils-5.4.0:0= )
- selinux? ( sys-libs/libselinux:0= )
- uuid? ( sys-apps/util-linux )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="virtual/pkgconfig"
-
-PATCHES=(
- "${FILESDIR}/${P}-CVE-2023-33551.patch"
- "${FILESDIR}/${P}-CVE-2023-33552.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --disable-werror
- $(use_enable fuse)
- $(use_enable lz4)
- $(use_enable lzma)
- $(use_with selinux)
- $(use_with uuid)
- )
-
- econf "${myeconfargs[@]}"
-}