summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild')
-rw-r--r--sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild b/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
index 61289b005cc2..6b5cb5abcf12 100644
--- a/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
+++ b/sys-boot/syslinux/syslinux-6.04_pre1-r5.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-inherit toolchain-funcs flag-o-matic
+inherit toolchain-funcs flag-o-matic secureboot
DESCRIPTION="SYSLINUX, PXELINUX, ISOLINUX, EXTLINUX and MEMDISK bootloaders"
HOMEPAGE="https://www.syslinux.org/"
@@ -38,6 +38,10 @@ QA_WX_LOAD="usr/share/syslinux/*"
QA_PRESTRIPPED="usr/share/syslinux/.*"
QA_FLAGS_IGNORED=".*"
+pkg_setup() {
+ use efi && secureboot_pkg_setup
+}
+
src_prepare() {
local PATCHES=(
"${FILESDIR}/syslinux-6.03-sysmacros.patch"
@@ -85,4 +89,6 @@ src_install() {
fi
einstalldocs
dostrip -x /usr/share/syslinux
+
+ use efi && secureboot_auto_sign --in-place
}