summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'sci-chemistry')
-rw-r--r--sci-chemistry/mdtraj/files/mdtraj-1.9.7-python311.patch16
-rw-r--r--sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild6
2 files changed, 21 insertions, 1 deletions
diff --git a/sci-chemistry/mdtraj/files/mdtraj-1.9.7-python311.patch b/sci-chemistry/mdtraj/files/mdtraj-1.9.7-python311.patch
new file mode 100644
index 000000000000..303c819aaee4
--- /dev/null
+++ b/sci-chemistry/mdtraj/files/mdtraj-1.9.7-python311.patch
@@ -0,0 +1,16 @@
+Index: mdtraj/setup.py
+===================================================================
+--- mdtraj.orig/setup.py 2023-01-18 15:26:51.424826255 +0100
++++ mdtraj/setup.py 2023-01-18 15:26:51.420826223 +0100
+@@ -298,6 +298,10 @@
+
+ for e in extensions:
+ e.include_dirs.append(np.get_include())
+- metadata['ext_modules'] = cythonize(extensions, language_level=sys.version_info[0])
++ metadata['ext_modules'] = cythonize(
++ extensions,
++ language_level=sys.version_info[0],
++ force=True,
++ )
+
+ setup(**metadata)
diff --git a/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
index 997dacaa72dd..f1d744000147 100644
--- a/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
+++ b/sci-chemistry/mdtraj/mdtraj-1.9.7.ebuild
@@ -2,7 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{9..10} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 pypi
@@ -34,6 +34,10 @@ DEPEND="${RDEPEND}
distutils_enable_tests --install pytest
+PATCHES=(
+ "${FILESDIR}/${P}-python311.patch"
+)
+
python_prepare_all() {
sed -e "s:re.match('build.*(mdtraj.*)', output_dir).group(1):'.':g" \
-i basesetup.py || die