summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/enet/enet-1.2.2-r1.ebuild11
-rw-r--r--net-libs/enet/enet-1.3.13.ebuild7
2 files changed, 11 insertions, 7 deletions
diff --git a/net-libs/enet/enet-1.2.2-r1.ebuild b/net-libs/enet/enet-1.2.2-r1.ebuild
index b38533678dda..a0ddb70b8e30 100644
--- a/net-libs/enet/enet-1.2.2-r1.ebuild
+++ b/net-libs/enet/enet-1.2.2-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+DESCRIPTION="Relatively thin, simple and robust network communication layer on top of UDP"
HOMEPAGE="http://enet.bespin.org/"
SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
@@ -15,3 +15,8 @@ IUSE="static-libs"
src_configure() {
econf $(use_enable static-libs static)
}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
diff --git a/net-libs/enet/enet-1.3.13.ebuild b/net-libs/enet/enet-1.3.13.ebuild
index 55c0fcdcfa0b..0e307002387a 100644
--- a/net-libs/enet/enet-1.3.13.ebuild
+++ b/net-libs/enet/enet-1.3.13.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils ltprune
+EAPI=7
-DESCRIPTION="relatively thin, simple and robust network communication layer on top of UDP"
+DESCRIPTION="Relatively thin, simple and robust network communication layer on top of UDP"
HOMEPAGE="http://enet.bespin.org/"
SRC_URI="http://enet.bespin.org/download/${P}.tar.gz"
@@ -21,5 +20,5 @@ src_configure() {
src_install() {
default
- prune_libtool_files
+ find "${ED}" -name '*.la' -delete || die
}