summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/gloox/gloox-1.0.9.ebuild')
-rw-r--r--net-libs/gloox/gloox-1.0.9.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/net-libs/gloox/gloox-1.0.9.ebuild b/net-libs/gloox/gloox-1.0.9.ebuild
new file mode 100644
index 000000000000..51c93c5f4f77
--- /dev/null
+++ b/net-libs/gloox/gloox-1.0.9.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MY_P=${P/_/-}
+DESCRIPTION="A portable high-level Jabber/XMPP library for C++"
+HOMEPAGE="http://camaya.net/gloox"
+SRC_URI="http://camaya.net/download/${MY_P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ~ppc64 sparc x86"
+IUSE="debug gnutls idn ssl zlib"
+
+DEPEND="idn? ( net-dns/libidn )
+ gnutls? ( net-libs/gnutls )
+ ssl? ( dev-libs/openssl )
+ zlib? ( sys-libs/zlib )"
+
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_configure() {
+ econf \
+ $(use_enable debug debug) \
+ $(use_with idn libidn) \
+ $(use_with gnutls gnutls) \
+ $(use_with ssl openssl) \
+ $(use_with zlib zlib)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}