summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/getdns/getdns-1.5.1.ebuild6
-rw-r--r--net-dns/getdns/getdns-1.5.2-r2.ebuild6
-rw-r--r--net-dns/getdns/getdns-1.6.0_beta1-r2.ebuild6
3 files changed, 9 insertions, 9 deletions
diff --git a/net-dns/getdns/getdns-1.5.1.ebuild b/net-dns/getdns/getdns-1.5.1.ebuild
index 412a42a0a402..87cc0fa7363f 100644
--- a/net-dns/getdns/getdns-1.5.1.ebuild
+++ b/net-dns/getdns/getdns-1.5.1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit fcaps systemd user
+inherit fcaps systemd user tmpfiles
DESCRIPTION="Modern asynchronous DNS API"
HOMEPAGE="https://getdnsapi.net/"
@@ -64,7 +64,7 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/stubby.logrotate stubby
systemd_dounit "${S}"/stubby/systemd/stubby.service
- systemd_dotmpfilesd "${S}"/stubby/systemd/stubby.conf
+ dotmpfiles "${S}"/stubby/systemd/stubby.conf
fi
}
diff --git a/net-dns/getdns/getdns-1.5.2-r2.ebuild b/net-dns/getdns/getdns-1.5.2-r2.ebuild
index ed71355073db..62a0514b8c10 100644
--- a/net-dns/getdns/getdns-1.5.2-r2.ebuild
+++ b/net-dns/getdns/getdns-1.5.2-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit fcaps systemd user
+inherit fcaps systemd user tmpfiles
DESCRIPTION="Modern asynchronous DNS API"
HOMEPAGE="https://getdnsapi.net/"
@@ -69,7 +69,7 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/stubby.logrotate stubby
systemd_dounit "${S}"/stubby/systemd/stubby.service
- systemd_dotmpfilesd "${S}"/stubby/systemd/stubby.conf
+ dotmpfiles "${S}"/stubby/systemd/stubby.conf
fi
}
diff --git a/net-dns/getdns/getdns-1.6.0_beta1-r2.ebuild b/net-dns/getdns/getdns-1.6.0_beta1-r2.ebuild
index 543db3e2c784..ab3972e67e66 100644
--- a/net-dns/getdns/getdns-1.6.0_beta1-r2.ebuild
+++ b/net-dns/getdns/getdns-1.6.0_beta1-r2.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
_SRCURI_P="${P/%_beta1/-beta.1}"
-inherit cmake fcaps systemd
+inherit cmake fcaps systemd tmpfiles
DESCRIPTION="Modern asynchronous DNS API"
HOMEPAGE="https://getdnsapi.net/"
@@ -76,7 +76,7 @@ src_install() {
insinto /etc/logrotate.d
newins "${FILESDIR}"/stubby.logrotate stubby
systemd_dounit "${S}"/stubby/systemd/stubby.service
- systemd_dotmpfilesd "${S}"/stubby/systemd/stubby.conf
+ dotmpfiles "${S}"/stubby/systemd/stubby.conf
fi
}