summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/wireshark/wireshark-9999.ebuild')
-rw-r--r--net-analyzer/wireshark/wireshark-9999.ebuild11
1 files changed, 9 insertions, 2 deletions
diff --git a/net-analyzer/wireshark/wireshark-9999.ebuild b/net-analyzer/wireshark/wireshark-9999.ebuild
index a850f1953b70..87ec81e02281 100644
--- a/net-analyzer/wireshark/wireshark-9999.ebuild
+++ b/net-analyzer/wireshark/wireshark-9999.ebuild
@@ -18,7 +18,8 @@ else
SRC_URI="https://www.wireshark.org/download/src/all-versions/${P/_/}.tar.xz"
S="${WORKDIR}/${P/_/}"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86"
+ # Seems to break libvirt?
+ #KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc64 ~x86"
fi
LICENSE="GPL-2"
@@ -213,6 +214,12 @@ src_install() {
# FAQ is not required as is installed from help/faq.txt
dodoc AUTHORS ChangeLog NEWS README* doc/randpkt.txt doc/README*
+
+ # install headers
+ insinto /usr/include/wireshark
+ doins ws_diag_control.h ws_symbol_export.h \
+ "${BUILD_DIR}"/config.h
+
# If trying to remove this, try build e.g. libvirt first!
# At last check, Fedora is still doing this too.
local dir dirs=(
@@ -221,9 +228,9 @@ src_install() {
epan/dfilter
epan/dissectors
epan/ftypes
- epan/wmem
wiretap
wsutil
+ wsutil/wmem
)
for dir in "${dirs[@]}" ; do