summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/shodan/shodan-1.28.0.ebuild')
-rw-r--r--net-analyzer/shodan/shodan-1.28.0.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/net-analyzer/shodan/shodan-1.28.0.ebuild b/net-analyzer/shodan/shodan-1.28.0.ebuild
deleted file mode 100644
index 8c7d7860bc86..000000000000
--- a/net-analyzer/shodan/shodan-1.28.0.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-inherit distutils-r1
-
-DESCRIPTION="The official Python library for Shodan"
-HOMEPAGE="https://github.com/achillean/shodan-python"
-
-MY_PN="${PN}-python"
-
-if [[ ${PV} = "9999" ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/achillean/shodan-python.git"
-else
- SRC_URI="https://github.com/achillean/shodan-python/archive/refs/tags/${PV}.tar.gz -> ${P}.gh.tar.gz"
- S="${WORKDIR}/${MY_PN}-${PV}"
- KEYWORDS="amd64 ~loong x86"
-fi
-
-LICENSE="MIT"
-SLOT="0"
-
-RDEPEND="
- dev-python/click[${PYTHON_USEDEP}]
- dev-python/click-plugins[${PYTHON_USEDEP}]
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/requests-2.2.1[${PYTHON_USEDEP}]
- dev-python/xlsxwriter[${PYTHON_USEDEP}]
-"
-
-# Test requires API key
-RESTRICT="test"