summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-analyzer/arping/arping-2.21.ebuild')
-rw-r--r--net-analyzer/arping/arping-2.21.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/net-analyzer/arping/arping-2.21.ebuild b/net-analyzer/arping/arping-2.21.ebuild
index 889b70b2de49..6daaf2358a7a 100644
--- a/net-analyzer/arping/arping-2.21.ebuild
+++ b/net-analyzer/arping/arping-2.21.ebuild
@@ -2,9 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
inherit autotools fcaps
-DESCRIPTION="A utility to see if a specific IP address is taken and what MAC address owns it"
+DESCRIPTION="A utility to see if a specific IP is taken and what MAC owns it"
HOMEPAGE="http://www.habets.pp.se/synscan/programs.php?prog=arping"
SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${P}.tar.gz"
@@ -16,19 +17,23 @@ RESTRICT="!test? ( test )"
CDEPEND="
net-libs/libpcap
- net-libs/libnet:1.1
-"
+ net-libs/libnet:1.1"
DEPEND="
${CDEPEND}
- test? ( dev-libs/check )
-"
+ test? (
+ dev-libs/check
+ dev-python/subunit )"
RDEPEND="
${CDEPEND}
- !net-misc/iputils[arping(+)]
-"
+ !net-misc/iputils[arping(+)]"
+
FILECAPS=( cap_net_raw /usr/sbin/arping )
+
S=${WORKDIR}/${PN}-${P}
+# patch is in upstream master
+PATCHES=( "${FILESDIR}/arping-tests.patch" )
+
src_prepare() {
default
eautoreconf