summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/snipes')
-rw-r--r--games-action/snipes/files/snipes-1.0.4-ldflags.patch9
-rw-r--r--games-action/snipes/files/snipes-1.0.4-nongnulinker.patch20
-rw-r--r--games-action/snipes/snipes-1.0.4-r1.ebuild33
3 files changed, 28 insertions, 34 deletions
diff --git a/games-action/snipes/files/snipes-1.0.4-ldflags.patch b/games-action/snipes/files/snipes-1.0.4-ldflags.patch
new file mode 100644
index 000000000000..af1f40d02917
--- /dev/null
+++ b/games-action/snipes/files/snipes-1.0.4-ldflags.patch
@@ -0,0 +1,9 @@
+"fake" flags cause non-gnu linkers to fail, and need a way to pass raw flags.
+https://bugs.gentoo.org/369287
+--- a/Makefile
++++ b/Makefile
+@@ -54,3 +54,3 @@
+ $(INTERMEDIATE)/%.o: $(IMG)/%.pbm
+- $(LD) -r -b binary -z noexecstack -z really_noexecstack -z pretty_please_noexecstack -o $@ $<
++ $(LD) -r -b binary -z noexecstack $(RAW_LDFLAGS) -o $@ $<
+
diff --git a/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch b/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch
deleted file mode 100644
index 8bdaeef3e356..000000000000
--- a/games-action/snipes/files/snipes-1.0.4-nongnulinker.patch
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/Makefile 2011-12-18 17:24:28.795315064 +0100
-+++ b/Makefile 2011-12-18 17:24:59.005311478 +0100
-@@ -33,7 +33,7 @@
- IMGOBJ = $(OIMGS:%.pbm=$(INTERMEDIATE)/%.o)
-
- CFLAGS += `sdl-config --cflags` -I$(INTERMEDIATE)
--LDLIBS += `sdl-config --libs`
-+LDLIBS += `sdl-config --libs` -lm
- LDFLAGS += -Wl,-z,noexecstack
-
-
-@@ -52,7 +52,7 @@
-
- # Why does this result in an executable stack? Can I run my bitmaps? Do bitmaps behave like Conway's game of life, when run?
- $(INTERMEDIATE)/%.o: $(IMG)/%.pbm
-- $(LD) -r -b binary -z noexecstack -z really_noexecstack -z pretty_please_noexecstack -o $@ $<
-+ $(LD) -r -b binary -z noexecstack -o $@ $<
-
- snipes.6: snipes.6.in
- sed s/'`VERSION`'/`cat VERSION`/ < $< > $@
diff --git a/games-action/snipes/snipes-1.0.4-r1.ebuild b/games-action/snipes/snipes-1.0.4-r1.ebuild
index 666172514c64..6b6beac3a3a4 100644
--- a/games-action/snipes/snipes-1.0.4-r1.ebuild
+++ b/games-action/snipes/snipes-1.0.4-r1.ebuild
@@ -1,35 +1,40 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
-inherit desktop toolchain-funcs
+inherit desktop flag-o-matic toolchain-funcs
DESCRIPTION="2D scrolling shooter, resembles the old DOS game of same name"
-HOMEPAGE="https://cyp.github.com/snipes/"
-SRC_URI="https://cyp.github.com/snipes/${P}.tar.gz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="media-libs/libsdl[sound,video]"
-RDEPEND=${DEPEND}
+RDEPEND="media-libs/libsdl[sound,video]"
+DEPEND="${RDEPEND}"
PATCHES=(
- "${FILESDIR}"/${P}-nongnulinker.patch
+ "${FILESDIR}"/${P}-ldflags.patch
)
src_compile() {
- tc-getLD
- default
+ tc-export CC LD
+
+ # lld requires arch flags to be passed even if native (bug #730852)
+ local archflags=
+ tc-ld-is-lld && eval archflags=\${LDFLAGS_${ARCH}}
+
+ LDLIBS=-lm emake RAW_LDFLAGS="${archflags} $(raw-ldflags)"
}
src_install() {
dobin snipes
doman snipes.6
- dodoc ChangeLog
+ einstalldocs
+
doicon ${PN}.png
- make_desktop_entry snipes "Snipes"
+ make_desktop_entry ${PN} ${PN^}
}