summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/patchelf/patchelf-0.9.ebuild')
-rw-r--r--dev-util/patchelf/patchelf-0.9.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/patchelf/patchelf-0.9.ebuild b/dev-util/patchelf/patchelf-0.9.ebuild
new file mode 100644
index 000000000000..71ca6a2b829e
--- /dev/null
+++ b/dev-util/patchelf/patchelf-0.9.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Small utility to modify the dynamic linker and RPATH of ELF executables"
+HOMEPAGE="http://nixos.org/patchelf.html"
+SRC_URI="http://releases.nixos.org/${PN}/${P}/${P}.tar.bz2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+LICENSE="GPL-3"
+
+src_prepare() {
+ default
+ rm src/elf.h || die
+
+ sed -i \
+ -e 's:-Werror::g' \
+ -e 's:parallel-tests:serial-tests:g' \
+ configure.ac || die
+
+ eautoreconf
+}