summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild')
-rw-r--r--dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild b/dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild
deleted file mode 100644
index 748cd174463f..000000000000
--- a/dev-ruby/idn-ruby/idn-ruby-0.1.0.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_EXTRADOC="CHANGES README"
-
-inherit ruby-fakegem
-
-DESCRIPTION="LibIDN Ruby Bindings"
-HOMEPAGE="https://github.com/deepfryed/idn-ruby"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64"
-IUSE=""
-
-RDEPEND+=" net-dns/libidn:0"
-DEPEND+=" net-dns/libidn:0"
-
-all_ruby_prepare() {
- # Avoid UTF-8 tests since we cannot guarantee a UTF-8 environment
- rm -f test/tc_Stringprep.rb || die
-}
-
-each_ruby_prepare() {
- mkdir lib || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext extconf.rb || die
-}
-
-each_ruby_compile() {
- emake V=1 -Cext
- cp ext/idn.so lib/ || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/*.rb"].each{|f| require f}' || die
-}