summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild')
-rw-r--r--dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild b/dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild
new file mode 100644
index 000000000000..57905842cfbe
--- /dev/null
+++ b/dev-ruby/celluloid-extras/celluloid-extras-0.20.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+USE_RUBY="ruby20 ruby21"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGES.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a simple and natural way to build fault-tolerant concurrent programs"
+HOMEPAGE="https://github.com/celluloid/celluloid"
+SRC_URI="https://github.com/celluloid/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+IUSE=""
+SLOT="0"
+
+LICENSE="MIT"
+KEYWORDS="~amd64"
+
+ruby_add_rdepend "
+ >=dev-ruby/timers-4.1.1"
+
+ruby_add_bdepend "test? (
+ dev-ruby/celluloid
+ dev-ruby/dotenv
+ dev-ruby/nenv
+ dev-ruby/rspec-retry
+)"
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' -e '/coveralls/I s:^:#:' spec/spec_helper.rb || die
+}