summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/genpy/genpy-0.6.2.ebuild')
-rw-r--r--dev-ros/genpy/genpy-0.6.2.ebuild34
1 files changed, 0 insertions, 34 deletions
diff --git a/dev-ros/genpy/genpy-0.6.2.ebuild b/dev-ros/genpy/genpy-0.6.2.ebuild
deleted file mode 100644
index d7ce7af9a1a1..000000000000
--- a/dev-ros/genpy/genpy-0.6.2.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-ROS_REPO_URI="https://github.com/ros/genpy"
-KEYWORDS="~amd64 ~arm"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit ros-catkin
-
-DESCRIPTION="Python ROS message and service generators"
-HOMEPAGE="http://wiki.ros.org/genpy"
-LICENSE="BSD"
-SLOT="0/${PV}"
-IUSE=""
-
-RDEPEND="dev-ros/genmsg[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )
-"
-
-python_test() {
- cd "${BUILD_DIR}"
- PYTHONPATH="${S}/src" nosetests --verbose -w "${S}/test" || die
-}
-
-src_test() {
- python_foreach_impl python_test
-}