summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ros/driver_base')
-rw-r--r--dev-ros/driver_base/Manifest1
-rw-r--r--dev-ros/driver_base/driver_base-1.6.9.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-ros/driver_base/Manifest b/dev-ros/driver_base/Manifest
index bf27cd3bcb9d..3c2c50627dce 100644
--- a/dev-ros/driver_base/Manifest
+++ b/dev-ros/driver_base/Manifest
@@ -1 +1,2 @@
DIST driver_common-1.6.8.tar.gz 15055 BLAKE2B 2d9a4c23d65b8e2f60343f5e3b454e1cc41334d34e0246891b533f216acb743df628d95dd2c0087b06284a85e0ea872baad495a7ed7b59c03e8f8ff32eba4ed8 SHA512 b698143d08785088ac13e62f5b96676bd590a84e4ffb147fa3698be6a8ded510f648d043ecdc1d31ba7b95fb3041d06ee1a39b224c359b8612adebdba259d188
+DIST driver_common-1.6.9.tar.gz 15374 BLAKE2B 88bcba03596d9a641091d37db8329807cfa0d4dd766298a25f8e41b6da567eb246fdd8c4c8a39698b60a47a118b81b15c3ac93154490a1258d93d3e2fbd5c049 SHA512 1a5f7d261a3e754b380824256d35432cee521b7d255a7f152b6a69d5181ea45a2bbca7a7c6d4e0bea753c8f3c59018a63357c87d2535a9cb55ba311f11e5d749
diff --git a/dev-ros/driver_base/driver_base-1.6.9.ebuild b/dev-ros/driver_base/driver_base-1.6.9.ebuild
new file mode 100644
index 000000000000..1931a276ceea
--- /dev/null
+++ b/dev-ros/driver_base/driver_base-1.6.9.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+ROS_REPO_URI="https://github.com/ros-drivers/driver_common"
+CATKIN_HAS_MESSAGES=yes
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Framework for writing drivers"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-libs/boost:="
+DEPEND="${RDEPEND}"