summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/wheel')
-rw-r--r--dev-python/wheel/Manifest4
-rw-r--r--dev-python/wheel/wheel-0.37.1-r1.ebuild67
-rw-r--r--dev-python/wheel/wheel-0.38.0.ebuild65
-rw-r--r--dev-python/wheel/wheel-0.38.2.ebuild66
-rw-r--r--dev-python/wheel/wheel-0.38.3.ebuild66
5 files changed, 0 insertions, 268 deletions
diff --git a/dev-python/wheel/Manifest b/dev-python/wheel/Manifest
index de1f40c3ce27..e1612f697eda 100644
--- a/dev-python/wheel/Manifest
+++ b/dev-python/wheel/Manifest
@@ -1,5 +1 @@
-DIST wheel-0.37.1.gh.tar.gz 68751 BLAKE2B 55919649f82668565d3b5907d14d0758984bb7d29d8857807ad034288ed8c9e8660957dc16f418f18408e89a97cf0d3c30df874a17f56deb56918388b18246a7 SHA512 9493db2f29e16d17ca06a4d47854b3df5dfd17f21c77efd42befd54470858256fd59f56aa9585cbf0a09830927b657d546324f793e1b1153665bf0b74d0c0457
-DIST wheel-0.38.0.gh.tar.gz 68696 BLAKE2B 38dbc8ba7cf67d202c6c98b277e590b3b31b46b698f59f988af1710e9fa6e5d2125378029475060cf3142cd9666bb318005619d085ea2e8b501bb10cd9694fe3 SHA512 0ffdf531c03d1f0866632002b163fdf8642b613604e74d1cfa5844e8c327946baf303bc0410fc7ec034f8a79cb4ad59536dfdaaa5cc8fa23a3b7d21faf5e6161
-DIST wheel-0.38.2.gh.tar.gz 69346 BLAKE2B 619da7f17d82837d70cb86bf6481738a4959c70f1be56ad68f87380f4f03efc588ada7af1b6892079833df50e4aa57f7453b811b616b8440e388bad701726572 SHA512 59a55e35f641dc6e97bcd58755ef39dd771f8ed442843321878054db3c54234befde368ae500a93fffde6ea1bbcb0e3981975b2c7574fc5a58693a70430e474b
-DIST wheel-0.38.3.gh.tar.gz 69385 BLAKE2B ff1c9681a361643877b1838d7fb2679f7b542152fa8f6268050bd1d7aefe75854e878036f4051e7e562f24973c4769948975060caa969ed8c13fd5259668da78 SHA512 e7a9b922fad3552b60d86123b002762e6a672253fdad8580c93ccea8c57619d450345c948b5e36857b264b7214860ee7f77650f7a269f455c2aa952116023798
DIST wheel-0.38.4.gh.tar.gz 69770 BLAKE2B a6077e38c21626169d68a3256fbe6457de3d4fde5d0a582859fe7b9ec5d73c142538f7fbfe762ddd436473c682e7810407a08730f66ec2a7844084d349e0779f SHA512 2ff7c6175201f8145f2c1f9937c6955a1dd22eeedab1e456f65c4edae9186610d9e7702c35773b49026c56c9cc201672025e7d42fcc7f782153c65c28e6b90d0
diff --git a/dev-python/wheel/wheel-0.37.1-r1.ebuild b/dev-python/wheel/wheel-0.37.1-r1.ebuild
deleted file mode 100644
index 8b1ef52db3b6..000000000000
--- a/dev-python/wheel/wheel-0.37.1-r1.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="
- https://github.com/pypa/wheel/
- https://pypi.org/project/wheel/
-"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed \
- -e 's:--cov --cov-config=setup.cfg::g' \
- -i setup.cfg || die
-
- # unbundle packaging
- rm -r src/wheel/vendored || die
- sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
-
- distutils-r1_src_prepare
-}
-
-src_configure() {
- [[ -e pyproject.toml ]] &&
- die "Upstream added pyproject.toml, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "wheel"
- description = "A built-package format for Python"
- dynamic = ["version"]
-
- [project.scripts]
- wheel = "wheel.cli:main"
-
- [project.entry-points."distutils.commands"]
- bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
- EOF
-}
diff --git a/dev-python/wheel/wheel-0.38.0.ebuild b/dev-python/wheel/wheel-0.38.0.ebuild
deleted file mode 100644
index 75f0055a893c..000000000000
--- a/dev-python/wheel/wheel-0.38.0.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="
- https://github.com/pypa/wheel/
- https://pypi.org/project/wheel/
-"
-SRC_URI="
- https://github.com/pypa/wheel/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unbundle packaging
- rm -r src/wheel/vendored || die
- sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
-
- distutils-r1_src_prepare
-}
-
-src_configure() {
- [[ -e pyproject.toml ]] &&
- die "Upstream added pyproject.toml, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "wheel"
- description = "A built-package format for Python"
- dynamic = ["version"]
-
- [project.scripts]
- wheel = "wheel.cli:main"
-
- [project.entry-points."distutils.commands"]
- bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
- EOF
-}
diff --git a/dev-python/wheel/wheel-0.38.2.ebuild b/dev-python/wheel/wheel-0.38.2.ebuild
deleted file mode 100644
index 24e78cab73d7..000000000000
--- a/dev-python/wheel/wheel-0.38.2.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="
- https://github.com/pypa/wheel/
- https://pypi.org/project/wheel/
-"
-SRC_URI="
- https://github.com/pypa/wheel/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unbundle packaging
- rm -r src/wheel/vendored || die
- sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
- sed -i -e 's:wheel\.vendored\.::' tests/*.py || die
-
- distutils-r1_src_prepare
-}
-
-src_configure() {
- [[ -e pyproject.toml ]] &&
- die "Upstream added pyproject.toml, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "wheel"
- description = "A built-package format for Python"
- dynamic = ["version"]
-
- [project.scripts]
- wheel = "wheel.cli:main"
-
- [project.entry-points."distutils.commands"]
- bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
- EOF
-}
diff --git a/dev-python/wheel/wheel-0.38.3.ebuild b/dev-python/wheel/wheel-0.38.3.ebuild
deleted file mode 100644
index 24e78cab73d7..000000000000
--- a/dev-python/wheel/wheel-0.38.3.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# please keep this ebuild at EAPI 7 -- sys-apps/portage dep
-EAPI=7
-
-DISTUTILS_USE_PEP517=flit
-PYTHON_COMPAT=( python3_{8..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="
- https://github.com/pypa/wheel/
- https://pypi.org/project/wheel/
-"
-SRC_URI="
- https://github.com/pypa/wheel/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos ~x64-solaris"
-
-RDEPEND="
- dev-python/packaging[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/setuptools[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # unbundle packaging
- rm -r src/wheel/vendored || die
- sed -i -e 's:\.vendored\.::' src/wheel/*.py || die
- sed -i -e 's:wheel\.vendored\.::' tests/*.py || die
-
- distutils-r1_src_prepare
-}
-
-src_configure() {
- [[ -e pyproject.toml ]] &&
- die "Upstream added pyproject.toml, recheck"
- # write a custom pyproject.toml to ease setuptools bootstrap
- cat > pyproject.toml <<-EOF || die
- [build-system]
- requires = ["flit_core >=3.2,<4"]
- build-backend = "flit_core.buildapi"
-
- [project]
- name = "wheel"
- description = "A built-package format for Python"
- dynamic = ["version"]
-
- [project.scripts]
- wheel = "wheel.cli:main"
-
- [project.entry-points."distutils.commands"]
- bdist_wheel = "wheel.bdist_wheel:bdist_wheel"
- EOF
-}