summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/vncdotool/vncdotool-1.0.0.ebuild')
-rw-r--r--dev-python/vncdotool/vncdotool-1.0.0.ebuild10
1 files changed, 4 insertions, 6 deletions
diff --git a/dev-python/vncdotool/vncdotool-1.0.0.ebuild b/dev-python/vncdotool/vncdotool-1.0.0.ebuild
index de7a237c2740..122de63db2a3 100644
--- a/dev-python/vncdotool/vncdotool-1.0.0.ebuild
+++ b/dev-python/vncdotool/vncdotool-1.0.0.ebuild
@@ -3,9 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Command line VNC client"
@@ -16,8 +14,9 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 x86"
-# No clue why this happens:
+# A lot of errors such as the following appear
# pexpect.exceptions.ExceptionPexpect: The command was not found or was not executable: vncev.
+# to install those, a manual compile and install of examples from net-libs/libvncserver is needed
RESTRICT="test"
BDEPEND="test? (
@@ -30,8 +29,7 @@ BDEPEND="test? (
dev-python/tox[${PYTHON_USEDEP}]
dev-python/virtualenv[${PYTHON_USEDEP}]
)"
-
-DEPEND="
+RDEPEND="
dev-python/pillow[${PYTHON_USEDEP}]
dev-python/twisted[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]