summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pyClamd')
-rw-r--r--dev-python/pyClamd/Manifest1
-rw-r--r--dev-python/pyClamd/metadata.xml11
-rw-r--r--dev-python/pyClamd/pyClamd-0.3.10.ebuild26
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/pyClamd/Manifest b/dev-python/pyClamd/Manifest
new file mode 100644
index 000000000000..3cf9e391fbf5
--- /dev/null
+++ b/dev-python/pyClamd/Manifest
@@ -0,0 +1 @@
+DIST pyClamd-0.3.10.tar.gz 8929 SHA256 ed77743c32298b151c881cc52a211e188bd24203ae402f2640def858c6a2bca7 SHA512 2c895fbc5897646ad5c23445062fb2e34a2db070471afd8356796f5f458d90b0da824af58b8ba762ce49572acaee6981881169eb33231085dac82ff0169fa2c8 WHIRLPOOL fa9ba64ab721169373572e552450fcee96db0499a9eeb336763ed2ea9e6f24328aece3b46a2c04ba2a6706f8d6a047ea0ef96f1fe53a6ae4663be0980d9e9c43
diff --git a/dev-python/pyClamd/metadata.xml b/dev-python/pyClamd/metadata.xml
new file mode 100644
index 000000000000..59353d2ff6c3
--- /dev/null
+++ b/dev-python/pyClamd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>xmw@gentoo.org</email>
+ <name>Michael Weber</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyClamd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyClamd/pyClamd-0.3.10.ebuild b/dev-python/pyClamd/pyClamd-0.3.10.ebuild
new file mode 100644
index 000000000000..2f8fd3a2da60
--- /dev/null
+++ b/dev-python/pyClamd/pyClamd-0.3.10.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="python interface to Clamd (Clamav daemon)"
+HOMEPAGE="http://xael.org/norman/python/pyclamd/"
+SRC_URI="mirror://pypi/p/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -e 's:/etc/clamav/clamd.conf:/etc/clamd.conf:' \
+ -i pyclamd/pyclamd.py || die
+}