summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/pgasync')
-rw-r--r--dev-python/pgasync/Manifest1
-rw-r--r--dev-python/pgasync/metadata.xml6
-rw-r--r--dev-python/pgasync/pgasync-2.01-r1.ebuild32
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/pgasync/Manifest b/dev-python/pgasync/Manifest
new file mode 100644
index 000000000000..82b9c248d484
--- /dev/null
+++ b/dev-python/pgasync/Manifest
@@ -0,0 +1 @@
+DIST pgasync-2.01.tar.gz 22314 SHA256 c38ac6ae200d54c22ad480ea020e0019692e69992344abce287232b30ccfe56c SHA512 36916ce3dcebf82367eace8fd689e0d300ffc040250869794191bfb723053050c9766fa5ce251341c317f7fbab418ace4dc36345d5c73eea92c1d04d36e802af WHIRLPOOL 6ac847535e7e8efdc28cf64323b302ee590bb38103049d19bc8f41aab6d2c9ec50d0493da0fea014e44f610871aed446c713e58b46f80db6414195b6d6327ab3
diff --git a/dev-python/pgasync/metadata.xml b/dev-python/pgasync/metadata.xml
new file mode 100644
index 000000000000..664c1a06cc54
--- /dev/null
+++ b/dev-python/pgasync/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>postgresql</herd>
+ <herd>python</herd>
+</pkgmetadata>
diff --git a/dev-python/pgasync/pgasync-2.01-r1.ebuild b/dev-python/pgasync/pgasync-2.01-r1.ebuild
new file mode 100644
index 000000000000..4bb12ae62417
--- /dev/null
+++ b/dev-python/pgasync/pgasync-2.01-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="An asynchronous API to PostgreSQL for twisted"
+HOMEPAGE="http://www.jamwt.com/pgasync/"
+SRC_URI="http://www.jamwt.com/pgasync/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc"
+
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+DOCS="CHANGELOG PKG-INFO README TODO"
+
+src_install() {
+ distutils-r1_python_install_all
+
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}