summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-python/ipdb/ipdb-0.10.2.ebuild')
-rw-r--r--dev-python/ipdb/ipdb-0.10.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/ipdb/ipdb-0.10.2.ebuild b/dev-python/ipdb/ipdb-0.10.2.ebuild
new file mode 100644
index 000000000000..362814e2d219
--- /dev/null
+++ b/dev-python/ipdb/ipdb-0.10.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="IPython-enabled pdb"
+HOMEPAGE="https://pypi.python.org/pypi/ipdb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/backports-shutil_get_terminal_size[${PYTHON_USEDEP}]' python2_7)
+ "
+
+DOCS=( HISTORY.txt )
+
+python_test() {
+ esetup.py test
+}