summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/core/core-0.15.1.ebuild')
-rw-r--r--dev-ml/core/core-0.15.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/core/core-0.15.1.ebuild b/dev-ml/core/core-0.15.1.ebuild
new file mode 100644
index 000000000000..0aecee5161f4
--- /dev/null
+++ b/dev-ml/core/core-0.15.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Jane Street's alternative to the standard library"
+HOMEPAGE="https://github.com/janestreet/core"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+# TODO: Wants quickcheck_deprecated?
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.11
+ dev-ml/base_bigstring:${SLOT}
+ dev-ml/ppx_jane:${SLOT}
+ dev-ml/ppx_pipebang:=
+ dev-ml/ppxlib:=
+ >=dev-ml/base-0.15.1:${SLOT}
+"
+DEPEND="${RDEPEND}"