summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-ml/alcotest/alcotest-0.7.2.ebuild')
-rw-r--r--dev-ml/alcotest/alcotest-0.7.2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/alcotest/alcotest-0.7.2.ebuild b/dev-ml/alcotest/alcotest-0.7.2.ebuild
new file mode 100644
index 000000000000..8b176af1f7e0
--- /dev/null
+++ b/dev-ml/alcotest/alcotest-0.7.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="A lightweight and colourful test framework"
+HOMEPAGE="https://github.com/mirage/alcotest/"
+SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-lang/ocaml:=[ocamlopt]
+ dev-ml/fmt:=
+ dev-ml/astring:=
+ dev-ml/cmdliner:=
+ dev-ml/result:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md README.md
+}